zoukankan      html  css  js  c++  java
  • HDU——1013Digital Roots(九余数定理)

    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 64420    Accepted Submission(s): 20053


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     


     

    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     


     

    Output
    For each integer in the input, output its digital root on a separate line of the output.
     


     

    Sample Input
    24 39 0
     


     

    Sample Output
    6 3

    交了七次才对。题意就是求数根,求法就是将数字每一位相加,若和为两位以上,继续相加,直至只有一位。若只有一位数,数根就是本身。否则重复求直到加出来的数只有一位。

     

    此外引用一个九余数定理:

    一个数对九取余后的结果称为九余数。

    一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

     

    代码:

    #include<iostream>
    #include<string>
    #include<sstream>
    using namespace std;
    int jisuan(const string &str)
    {
    
    	int sum=0;
    	if(str.size()==1)
    		return sum=str[0]-'0';
    	for (int i=0; i<str.size(); i++)
    	{
    		sum=sum+(str[i]-'0')%9;//各位相加的和取模9,等于各位取模9后的和
    	}
    	return sum;
    }
    int main(void)
    {
    	int n;
    	string str;
    	int num;
    	while (cin>>str&&str!="0")
    	{
    		num=jisuan(str);
    		while (num>=10)
    		{
    			string t;
    			ostringstream oin;
    			oin<<num;
    			t=oin.str();
    			num=jisuan(t);
    		}
    		if(num%9==0)//一直WA因为只判断了9而没有判断它的倍数
    			cout<<9<<endl;
    		else
    		cout<<num<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    802.11帧
    art中的部分内容,留着慢慢研究
    802.11基础知识
    opkg
    openwrt生成备份文件
    lua中获取时间
    php学习四:数组(一)
    php学习三:函数
    php学习二:表达式
    php学习一:语法规则
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356445.html
Copyright © 2011-2022 走看看