zoukankan      html  css  js  c++  java
  • PAT 1019 General Palindromic Number[简单]

    1019 General Palindromic Number (20)(20 分)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits a~i~ as the sum of (a~i~b^i^) for i from 0 to k. Here, as usual, 0 <= a~i~ < b for all i and a~k~ is non-zero. Then N is palindromic if and only if a~i~ = a~k-i~ for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 10^9^ is the decimal number and 2 <= b <= 10^9^ is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "a~k~ a~k-1~ ... a~0~". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1

    //题目大意是说:给出来一个数和数的基数d,并且判断在这个数在d进制下是否是回文数字。真的可以说是非常简单了。

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <vector>
    
    using namespace std;
    vector<long> v;
    int main()
    {
        long n,d,t;
        scanf("%lld%lld",&n,&d);
        if(n==0){
            printf("Yes\n0");
            return 0;
        }
        while(n!=0){
            t=n%d;
            n=n/d;
            v.push_back(t);
        }
        t=v.size();
        bool flag=true;
        for(int i=0;i<t/2;i++){
            if(v[i]!=v[t-i-1]){
                flag=false;break;
            }
        }
    
        if(flag)printf("Yes\n");
        else printf("No\n");
        printf("%lld",v[t-1]);//倒序输出
        for(int i=t-2;i>=0;i--)
            printf(" %lld",v[i]);
        return 0;
    }

    //但是我还是提交错了,因为N输入可能是0,我没有考虑到这个特殊情况special case。。。。每次提交之后很多种情况都是发现这个出问题了。

  • 相关阅读:
    MO 中的imagelayer
    GDAL之OGR入门(转载)
    OGR体系结构
    C++与C# 以及指针
    如何用C#编程实现动态生成Word文档并填充数据?
    C++的类与C#的类[zt]
    arcmap vba 实现“卫星立体测图”高度字段值的计算,今天的一点小成就
    lib 和 dll from baidu
    ping and netstat
    Visual Basic6.0 中的类模块和标准模块
  • 原文地址:https://www.cnblogs.com/BlueBlueSea/p/9429576.html
Copyright © 2011-2022 走看看