zoukankan      html  css  js  c++  java
  • HDOJ 1677 Nested Dolls(LIS+Dilworth)




    Nested Dolls

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1805    Accepted Submission(s): 501


    Problem Description
    Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
     

    Input
    On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
     

    Output
    For each test case there should be one line of output containing the minimum number of nested dolls possible.
     

    Sample Input
    4
    3
    20 30 40 50 30 40
    4
    20 30 10 10 30 20 40 50
    3
    10 30 20 20 30 10
    4
    10 10 20 30 40 50 39 51
     

    Sample Output
    1
    2
    3
    2
     

    Source
     

    Recommend
    lcy
     



    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>

    using namespace std;

    struct Node
    {
        int w,h;
    }p[22222];

    bool cmp(Node a,Node b)
    {
        if(a.w!=b.w)
        {
            return a.w>b.w;
        }
        else
        {
            return a.h<b.h;
        }
    }

    int main()
    {
        int T;
        scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p.w,&p.h);
        }
        sort(p,p+n,cmp);
        int as[22222]={0};
        for(int i=0;i<n;i++)
        {
            as=p.h;
        }

        int cnt=0;int i,j;
        for(i=0;i<n;i++)
        {
            for(j=0;j<cnt;j++)
            {
                if(as<as[j])
                    break;
            }
            if(j==cnt) cnt++;
            as[j]=as;
        }

       printf("%d ",cnt);
    }

        return 0;
    }


  • 相关阅读:
    JS-instanceof 与typeof
    JS-面向对象相关
    spark job源代码物理执行图实战
    堆(heap)和栈(stack)的区别
    sql developer怎样调试Pipelined
    oracle dbms_output 在java中输出
    sed 用法笔记
    oracle 怎样建自增长字段
    python学习笔记--split与join用法
    如何开启php报错
  • 原文地址:https://www.cnblogs.com/CKboss/p/3350990.html
Copyright © 2011-2022 走看看