题目链接:https://vjudge.net/problem/POJ-2478
Farey Sequence
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 17753 | Accepted: 7112 |
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
Source
POJ Contest,Author:Mathematica@ZSU
题解:
单纯的欧拉函数。
代码如下:
1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <algorithm> 5 #include <vector> 6 #include <cmath> 7 #include <queue> 8 #include <stack> 9 #include <map> 10 #include <string> 11 #include <set> 12 using namespace std; 13 typedef long long LL; 14 const int INF = 2e9; 15 const LL LNF = 9e18; 16 const int MOD = 1e9+7; 17 const int MAXN = 1e6+10; 18 19 int euler[MAXN]; 20 void getEuler() 21 { 22 memset(euler, 0, sizeof(euler)); 23 euler[1] = 1; 24 for(int i = 2; i<MAXN; i++) if(!euler[i]) { 25 for(int j = i; j<MAXN; j += i) 26 { 27 if(!euler[j]) euler[j] = j; 28 euler[j] = euler[j]/i*(i-1); 29 } 30 } 31 } 32 33 LL f[MAXN]; 34 void init() 35 { 36 getEuler(); 37 f[1] = 0; 38 for(int i = 2; i<MAXN; i++) 39 f[i] = f[i-1] + euler[i]; 40 } 41 42 int main() 43 { 44 int n; 45 while(scanf("%d", &n)&&n) 46 printf("%lld ", f[n]); 47 }