zoukankan      html  css  js  c++  java
  • POJ:2386 Lake Counting(dfs)

    Lake Counting
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 40370 Accepted: 20015

    Description

    Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

    Given a diagram of Farmer John's field, determine how many ponds he has.

    Input

    * Line 1: Two space-separated integers: N and M 

    * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

    Output

    * Line 1: The number of ponds in Farmer John's field.

    Sample Input

    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.

    Sample Output

    3

    Hint

    OUTPUT DETAILS: 

    There are three ponds: one in the upper left, one in the lower left,and one along the right side.

    Source


    题意:n行m列中,连在一起没有分开的W块有多少

    从任意的W开始,不停地把邻接的部分用 . 代替。一次dfs后与初始的这个W连接的所有W就都被替换成了 . 。因此直到图中不再存在W为止,总共进行的dfs次数就是答案。

    8个方向共对应了8种状态转移,每个格子作为dfs的参数至多被调用一次,复杂度为O(8*N*M)=O(N*M)

    AC代码:

    #include<cstdio>
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    using namespace std;
    int n,m;
    const int maxn=1e3+10;
    char ch[maxn][maxn];
    void dfs(int x,int y)
    {
    	ch[x][y]='.';
    	for(int dy=-1;dy<=1;dy++)
    	for(int dx=-1;dx<=1;dx++)
    	{
    		int nx=x+dx,ny=y+dy;
    		if(nx>=0&&nx<n&&ny>=0&&ny<m&&ch[nx][ny]=='W') dfs(nx,ny);//不断递归,把n*m区域内的W变成. 
    	}
    }
    int main()
    {
    	cin>>n>>m;
    	for(int i=0;i<n;i++)
    	for(int j=0;j<m;j++)
    	cin>>ch[i][j];
    	int sum=0;
    	for(int i=0;i<n;i++)
    	for(int j=0;j<m;j++)
    	{
    		if(ch[i][j]=='W')
    		{
    			dfs(i,j);
    			sum++;
    		}
    	}
    	cout<<sum<<endl;
    	return 0;
    }

  • 相关阅读:
    NET开发中的事务处理大比拼
    gridview 导出Excel
    项目 心得
    设计模式Prototype原型模式
    设计模式Memento 备忘录模式
    设计模式Chain Of Responsibility 职责链模式
    设计模式Composite组合模式
    .NET常用功能和代码[总结与收藏]
    SQL SERVER函数——表值函数的处理
    设计模式学习笔记 简单工厂模式
  • 原文地址:https://www.cnblogs.com/Friends-A/p/9309044.html
Copyright © 2011-2022 走看看