zoukankan      html  css  js  c++  java
  • HDU 1011 Starship Troopers【DP】

    Problem Description
    You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

    To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

    A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
     
    Input
    The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

    The last test case is followed by two -1's.
     
    Output
    For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
     
    Sample Input
    5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
     
    Sample Output
    50 7
     

    题意:一棵树有n各节点,每个节点有v个bugs, w个brain, 从1结点开始走,带领m个战士,每个战士打败20个bugs,注意如果50个bugs需要3个战士,且不可以再去打别的bugs,

    如果想打子节点必须打父节点,使得取得的brains最多。注意题目给的关系i, j并不是i是j的父节点,关系未知,只是联通。

    思路:树形DP,dp[i][j]表示打i结点的所用战士j取得的最大值。

    dp[i][j]=max{dp[i][j], dp[i][j-k]+dp[tt][k]}(这里的tt是i的子节点。

    相当于对子节点进行01背包。

    代码如下:

    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<vector>
    using namespace std;
    int use[105], brain[105], dp[105][105], visit[105]; 
    int m; 
    vector<int>v[105];
    void dfs(int root)
    {
        int i, j, k;
        visit[root]=1; 
        for(i=use[root]; i<=m; i++)
            dp[root][i]=brain[root]; 
        for(i=0; i<v[root].size(); i++)
        {
            if(visit[v[root][i]]==1)
                continue; 
            dfs(v[root][i]);
            //for(j=use[root]; j<=m; j++)
            for(j=m; j>=use[root]; j--) 
                for(k=1; k<=j; k++)
                    if(j-k>=use[root]) 
                        dp[root][j]=max(dp[root][j], dp[root][j-k]+dp[v[root][i]][k]);
        }
    } 
    int main()
    {
        int n, i, j, k, a, b;
        while(scanf("%d%d", &n, &m)!=EOF)
        {
            if(n==-1&&m==-1)
                break;
            memset(use, 0, sizeof(use));
            memset(brain, 0, sizeof(brain));
            memset(dp, 0, sizeof(dp));
            memset(visit, 0, sizeof(visit)); 
            for(i=1; i<=n; i++)
            {
                scanf("%d%d", &a, &b);
                use[i]=(a+19)/20, brain[i]=b;
            }
            for(i=0; i<=100; i++)
                v[i].clear(); 
            for(i=1; i<n; i++)
            {
                scanf("%d%d", &a, &b);
                v[a].push_back(b);
                v[b].push_back(a);
            }
            if(m==0)
            { printf("0\n"); continue;} 
            dfs(1);
            printf("%d\n", dp[1][m]);
        }
      return 0;
    }
  • 相关阅读:
    CocoaPods的安装使用和常见问题
    超全iOS面试资料,看完你还担心面试吗?
    IOS--多线程之线程间通讯
    iOS开发网络篇—发送GET和POST请求(使用NSURLSession)
    java之NIO编程
    libthrift0.9.0解析(四)之TThreadPoolServer&ServerContext
    android开发笔记
    rtsp转发服务器设计
    神经网络文献资料
    deep learning in nlp 资料文献
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616809.html
Copyright © 2011-2022 走看看