zoukankan      html  css  js  c++  java
  • 1004. Counting Leaves (30)

    1004. Counting Leaves (30)

     
    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    
    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input
    2 1
    01 1 02
    
    Sample Output
    0 1





    有关树的遍历的问题,用到了深搜的方法
    树的存放很有意思,map<int,vector<int> >; key为某个节点的ID,vector是他的孩子ID数组


    #include <iostream>
    #include <map>
    #include <vector>
    
    using namespace std;
    
    map<int,vector<int> > adjlist;
    int levelleaves[105]={0};
    
    void dfs(int node,int level){
        if(adjlist[node].empty()){
            levelleaves[level]++;
            return;
        }
        vector<int>:: iterator itea = adjlist[node].begin();
        for(;itea!=adjlist[node].end();itea++){
            dfs(*itea,level+1);
        }
    }
    
    
    int main()
    {
        int n,m;
        cin>>n>>m;
        int leaves = n-m;
        for(int i=0;i<m;i++){
            int id1,k, id2;
            cin>>id1>>k;
            for(int j=0;j<k;j++){
                cin>>id2;
                adjlist[id1].push_back(id2);
            }
        }
        dfs(1,0);
        int a=levelleaves[0];
        cout<<levelleaves[0];
        for(int i=1;a<leaves;i++){
            cout<<" "<<levelleaves[i];
            a=a+levelleaves[i];
        }
        return 0;
    }







  • 相关阅读:
    Angular2基础03: 理解依赖注入
    关于HTPP状态码的实践:307的使用
    Angular2基础03:如何重置表单的验证状态?
    Angular2基础02:模板引用变量的使用
    Angular2基础01:理解及时编译(JIT)
    cordova05:配置应用图标与启动画面
    连续子数组的最大和
    从1到整数n中1出现的次数
    滑动窗口的最大值
    矩阵中的路径
  • 原文地址:https://www.cnblogs.com/Qmelbourne/p/6057337.html
Copyright © 2011-2022 走看看