zoukankan      html  css  js  c++  java
  • POJ 3176 简单DP

    Cow Bowling
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 16448 Accepted: 10957
    Description

    The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7
    
    
    
        3   8
    
    
    
      8   1   0
    
    
    
    2   7   4   4
    

    4 5 2 6 5
    Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

    Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
    Input

    Line 1: A single integer, N

    Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
    Output

    Line 1: The largest sum achievable using the traversal rules
    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5
    Sample Output

    30
    Hint

    Explanation of the sample:

          7
    
         *
    
        3   8
    
       *
    
      8   1   0
    
       *
    
    2   7   4   4
    
       *
    

    4 5 2 6 5
    The highest score is achievable by traversing the cows as shown above.

    题意:一个n层的三角形,从第一行第一列开始向下走,每次只能向下一行且只能走到与之到相邻的两块,求到最后一行路程的最大值。

    解题思路:动规
    f[i][j]表示到第i行第j列路程的最大值
    走到第i行第j列的路程只能与走到第i-1行第j列和第i-1行第i-1列有关
    不难写出状态转移方程为:f[i][j]=max(f[i][j]+f[i-1][j-1],f[i][j]+f[i-1][j]);

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int n,f[666][666];
    int main()
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                scanf("%d",&f[i][j]);
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                f[i][j]=max(f[i][j]+f[i-1][j-1],f[i][j]+f[i-1][j]);
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(f[n][i]>f[0][0]) f[0][0]=f[n][i]; 
        }
        printf("%d",f[0][0]);
    }
  • 相关阅读:
    c++ 11 thread 初试
    java UDP聊天与文件传输
    iOS 基础类解析
    Hadoop HA高可用集群搭建(2.7.2)
    object-c 不定參数的遍历和原理
    9.4 返回更新后的行
    java面向接口编程
    Node.js开发入门—套接字(socket)编程
    shell脚本输出带颜色字体
    shell--read命令
  • 原文地址:https://www.cnblogs.com/SiriusRen/p/5831198.html
Copyright © 2011-2022 走看看