zoukankan      html  css  js  c++  java
  • 1012——The Best Rank

    To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

    For example, The grades of C, M, E and A - Average of 4 students are given as the following:

    StudentID  C  M  E  A
    310101     98 85 88 90
    310102     70 95 88 84
    310103     82 87 94 88
    310104     91 91 91 91
    

    Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

    Input

    Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

    Output

    For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

    The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

    If a student is not on the grading list, simply output "N/A".

    Sample Input

    5 6
    310101 98 85 88
    310102 70 95 88
    310103 82 87 94
    310104 91 91 91
    310105 85 90 90
    310101
    310102
    310103
    310104
    310105
    999999
    

    Sample Output

    1 C
    1 M
    1 E
    1 A
    3 A
    N/A

    题库最有价值的确实是里面的数据,排序没有考虑排名相等的情况就会错。
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <cctype>
    #include <cstdlib>
    #include<cmath>
    #include <string>
    #include <map>
    #include <set>
    #include <queue>
    #include <vector>
    #include <stack>
    #include <cctype>
    using namespace std;
    typedef unsigned long long ull;
    #define INF 0xfffffff
    
    struct stu{
        int c,m,e,id,g[4];
        double a;
    }s[2001];
    
    int cmp1(stu A,stu B)
    {
        return A.a>B.a;
    }
    int cmp2(stu A,stu B)
    {
        return A.c>B.c;
    }
    int cmp3(stu A,stu B)
    {
        return A.m>B.m;
    }
    int cmp4(stu A,stu B)
    {
        return A.e>B.e;
    }
    
    int main()
    { 
        int x,y,n,m,i,j,k,ans;
    
        char c,gg[4]={'A','C','M','E'};
        cin>>n>>m;
        for(i=0;i<n;++i)
        {
            cin>>s[i].id>>s[i].c>>s[i].m>>s[i].e;
            s[i].a=(s[i].c+s[i].m+s[i].e)/3.0;
        }
        sort(s,s+n,cmp1);
        s[0].g[0]=1;
        for(i=1;i<n;++i)
        {
            if(s[i].a==s[i-1].a)
                s[i].g[0]=s[i-1].g[0];
            else
                s[i].g[0]=i+1;
        }
        sort(s,s+n,cmp2);
        s[0].g[1]=1;
        for(i=1;i<n;++i)
        {
            if(s[i].c==s[i-1].c)
                s[i].g[1]=s[i-1].g[1];
            else
                s[i].g[1]=i+1;
        }
        sort(s,s+n,cmp3);
        s[0].g[2]=1;
        for(i=1;i<n;++i)
        {
            if(s[i].m==s[i-1].m)
                s[i].g[2]=s[i-1].g[2];
            else
                s[i].g[2]=i+1;
        }
        sort(s,s+n,cmp4);
        s[0].g[3]=1;
        for(i=1;i<n;++i)
        {
            if(s[i].e==s[i-1].e)
                s[i].g[3]=s[i-1].g[3];
            else
                s[i].g[3]=i+1;
        }
        for(i=0;i<m;++i)
        {
            cin>>x;
            y=2001;
            for(j=0;j<n;++j)
            {
                if(x==s[j].id)
                {
                    for(k=0;k<4;++k)
                    {
                        if(y>s[j].g[k])
                        {
                            y=s[j].g[k];
                            c=gg[k];
                        }
                    }
                    break;
                }
            }
            if(j==n)
                cout<<"N/A"<<endl;
            else
                cout<<y<<" "<<c<<endl;
        }
      
      return 0;
    }
  • 相关阅读:
    Netty入门
    hashCode方法里为什么选择数字31作为生成hashCode值的乘数
    【转】String hashCode 方法为什么选择数字31作为乘子
    NppFTP小插件的使用
    事务的基础入门
    Code Review 程序员的寄望与哀伤【转载】
    谈谈敏捷开发【转载】
    如何写代码 — 编程内功心法【转载】
    面经【转载】
    Swagger的简单入门【转载】
  • 原文地址:https://www.cnblogs.com/Traveller-Leon/p/5034545.html
Copyright © 2011-2022 走看看