zoukankan      html  css  js  c++  java
  • Problem 2111 Min Number

                                                                                                                                                 Problem 2111 Min Number

    Accept: 925    Submit: 1838
    Time Limit: 1000 mSec    Memory Limit : 32768 KB

     Problem Description

    Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

    For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

    Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

    Please note that in this problem, leading zero is not allowed!

     Input

    The first line of the input contains an integer T (T≤100), indicating the number of test cases.

    Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

    Output

    For each test case, output the minimum number we can get after no more than M operations.

    Sample Input

    3 9012 0 9012 1 9012 2

     Sample Output

    9012 1092 1029 
     
    题意:给定一个数字,这个数字的任意两个数码可以进行调换,作为一次操作,但不管怎么换,不能出现前导0。现在能进行M次操作,问M次操作以内,任意的交换,找到该数字的最小值。
    思路:广度优先搜索,从初始的值开始搜索,一层一层的搜,搜到M层为止,找到最小值。
    AC代码:
    #define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<algorithm>
    #include<string>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<map>
    using namespace std;
    typedef long long ll;
    map<string, int>m;
    string s;
    int M;
    
    void swap(string &s,int i,int j) {
        char tmp = s[i];
        s[i] = s[j];
        s[j] = tmp;
    }
    
    string bfs(string &s) {
        m.insert(make_pair(s,0));
        queue<string>que;
        que.push(s);
        string MIN_num = s;
        while (!que.empty()) {
            string str = que.front();
            if (m[str] == M)break;
            que.pop();
            for (int i = 0; i < s.size();i++) {
                for (int j = i + 1; j < s.size(); j++) {
                    string tmp = str;
                    swap(tmp, i, j);
                    map<string,int>::iterator it = m.find(tmp);
                    if (it == m.end()&&tmp[0]!='0') {
                        que.push(tmp);
                        m.insert(make_pair(tmp,m[str]+1));
                        if (MIN_num > tmp) {
                            MIN_num = tmp;
                        }
                    }
                }
            }
        }
        return MIN_num;
    }
    
    int main() {
        int T;
        scanf("%d",&T);
        while (T--) {
            cin >> s;
            scanf("%d",&M);
            m.clear();
            cout << bfs(s) << endl;;
        }
        return 0;
    }
  • 相关阅读:
    动态设置ImageView的大小
    URI和URL、URN的区别
    关于Android中的异步任务
    Android下如何理解onMeasure,onLayout的过程
    Android如何获取同包名应用的图标及名称
    Android4.0 监听 android 手机情景模式(有声、静音、振动)
    Android中裁剪一张图片
    Json解析国家气象局天气API
    Android中AnimationDrawable的使用
    POJ
  • 原文地址:https://www.cnblogs.com/ZefengYao/p/6769562.html
Copyright © 2011-2022 走看看