zoukankan      html  css  js  c++  java
  • java实现 蓝桥杯 算法提高 Problem S4: Interesting Numbers 加强版

    1 问题描述
    Problem Description
      We call a number interesting, if and only if:
      1. Its digits consists of only 0, 1, 2 and 3, and all these digits occurred at least once.
      2. Inside this number, all 0s occur before any 1s, and all 2s occur before any 3s.
      Therefore, the smallest interesting number according to our definition is 2013. There are two more interseting number of 4 digits: 2031 and 2301.
      Your task is to calculate the number of interesting numbers of exactly n digits. As the answer might be very large, you only need to output the answer modulo 1000000007.
    Input Format
      The input has one line consisting of one positive integer n (4 ≤ n ≤ 10^15).
    Output Format
      The output has just one line, containing the number of interesting numbers of exactly n digits, modulo 1000000007.
    Input Sample
      4
    Output Sample
      3

    2 解决方案
    本题主要考查数学组合数推理化简,具体思考过程如下:

    在这里插入图片描述
    推导过程,在草稿纸上推导了一下:

    在这里插入图片描述

    import java.util.Scanner;
     
    public class Main {
    	static long n;
    	static long mul, ans, res;
    	static long monum = 1000000007;
     
    	private static long cal(long n) {
    		if (n == 1)
    			return 2;
    		long num = cal(n / 2);
    		num = num * num % monum;
    		if (n % 2 == 1)
    			num = num * 2 % monum;
    		return num;
    	}
     
    	public static void main(String[] args) {
    		// TODO Auto-generated method stub
    		Scanner reader = new Scanner(System.in);
    		n = reader.nextLong();
    		if (n == 4)
    			System.out.println(3);
    		else {
    			n = n - 1;
    			res = (n % monum) * (n % monum);
    			res = ((res - 3 * n) % monum + monum) % monum;
    			n = n - 2;
    			mul = cal(n);
    			res = res * mul % monum;
    			n = n + 2;
    			res = (res + n) % monum;
    			System.out.println(res);
    		}
    	}
     
    }
    
  • 相关阅读:
    设置MySQL的字符编码
    数据库面试题
    java.lang.IncompatibleClassChangeError: Implementing class
    下载SpringJar包
    使用命令wsimport构建WebService客户端
    java读取.properties配置文件的几种方法
    ELK5.X使用X-Pack配置密码
    Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'
    MySQL常用命令
    XPath常用定位节点元素语句总结
  • 原文地址:https://www.cnblogs.com/a1439775520/p/12947992.html
Copyright © 2011-2022 走看看