试题 算法提高 字符串压缩
资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
编写一个程序,输入一个字符串,然后采用如下的规则对该字符串当中的每一个字符进行压缩:
(1) 如果该字符是空格,则保留该字符;
(2) 如果该字符是第一次出现或第三次出现或第六次出现,则保留该字符;
(3) 否则,删除该字符。
例如,若用户输入“occurrence”,经过压缩后,字符c的第二次出现被删除,第一和第三次出现仍保留;字符r和e的第二次出现均被删除,因此最后的结果为:“ocurenc”。
输入格式:输入只有一行,即原始字符串。
输出格式:输出只有一行,即经过压缩以后的字符串。
输入输出样例
样例输入
occurrence
样例输出
ocurenc
PS:我是真的把题想复杂了,我单纯的以为,O2过不了,结果真的过了,感谢一位大佬的指点
package com.company;
import java.util.Scanner;
public class 字符串压缩 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String s = sc.nextLine();
sc.close();
char[] str = s.toCharArray();
int[] count = new int[str.length];
for (int i=0;i<str.length;i++){
for (int j=0;j<=i;j++){
if (str[i] == str[j]) {
count[i]++;
}
}
}
for (int i = 0; i < str.length; i++) {
if (count[i] == 1 || count[i] == 3 || count[i] == 6 || str[i] == ' ') {//次数为1,3,6和空格字符的保留
System.out.print(str[i]);
}
}
}
}