zoukankan      html  css  js  c++  java
  • poj1751最小生成树

    The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

    Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

    The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
    Input

    The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

    The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

    The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

    Output

    Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

    If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

    Sample Input

    9
    1 5
    0 0 
    3 2
    4 5
    5 1
    0 4
    5 2
    1 2
    5 3
    3
    1 3
    9 7
    1 2

    Sample Output

    1 6
    3 7
    4 9
    5 7
    8 3
    此题纠结了好久,重点是想办法输出,把所有更新了的节点记录,到下一次更新时输出
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    const double inf=1e20;
    double d[800],cost[800][800];
    int x[800],y[800];
    int n,m;
    struct node{
       double x,y;
    }e[800];
    double dis(node a,node b) {
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }
    void prim() {
        bool vis[800];
        for(int i=1;i<=n;i++)
        {
            vis[i]=0;
            d[i]=inf;
        }
        d[0]=0;
        int num=0;
        while(1){
            int v=-1;
            for(int i=1;i<=n;i++)
            {
                if(!vis[i]&&(v==-1||d[i]<d[v]))//找到最小的边
                    v=i;
            }
            if(v==-1)break;//无更新退出
            vis[v]=1;
            if(num&&cost[x[v]][y[v]])printf("%d %d ",x[v],y[v]);
            num=1;
            for(int i=1;i<=n;i++)
            {
                if(d[i]>cost[i][v])//把所有的边都更新一边
                {
                    d[i]=cost[i][v];
                    x[i]=i;
                    y[i]=v;
              /* if(cost[i][v]!=0) printf("%d %d ",i,v);//每次更新全部时,即使不是下一个节点,也是会被更新的,所以要只输出下一个节点的*/
                }
            }
        }
    }
    int main() {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%lf%lf",&e[i].x,&e[i].y);
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                cost[i][j]=cost[j][i]=dis(e[i],e[j]);
            }
            cost[i][i]=0;
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            cost[a][b]=cost[b][a]=0;
        }
        prim();
        return 0;
    }
  • 相关阅读:
    【我的物联网成长记5】如何进行物联网大数据分析?
    云图说|华为云数据库在线迁移大揭秘
    #化鲲为鹏,我有话说# 鲲鹏弹性云服务器配置 Tomcat
    JQuery中$.each 和$(selector).each()的区别详解【转】
    PHP 这个设置 ini_set('memory_limit', '200M') 的生效时间
    [转]PHP底层运行原理和zend编译机制学习
    [转]memcache 缓存图片 示例
    [转]memcache 和 redis 区别
    MYSQL 常用,有用语句
    php curl的几个例子【转】
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6483688.html
Copyright © 2011-2022 走看看