zoukankan      html  css  js  c++  java
  • POJ1995

    People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

    Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

    You should write a program that calculates the result and is able to find out who won the game. 
     

    Input

    The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

    Output

    For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

    (A1B1+A2B2+ ... +AHBH)mod M.

    Sample Input

    3
    16
    4
    2 3
    3 4
    4 5
    5 6
    36123
    1
    2374859 3029382
    17
    1
    3 18132
    

    Sample Output

    2
    13195
    13

    思路:这道题直接套模板,快速幂

    #include<iostream>
    #include<cstdio>
    #define maxn 45005
    using namespace std;
    long long powermod(long long a,long long b,long long c)
    {
        long long ans=1;
        a%=c;
        while(b)
        {
            if(b&1)
                ans=ans*a%c;
            b>>=1;
            a=a*a%c;
        }
        return ans;
    }
    int main()
    {
        long long t,m,z,sum,a,b;
        cin>>t;
        while(t--)
        {
            cin>>m>>z;
            sum=0;
            while(z--)
            {
                cin>>a>>b;
                sum+=powermod(a,b,m);
            }
            sum%=m;
            cout<<sum<<endl;
        }
        return 0;
    }
  • 相关阅读:
    洛谷P3674 小清新人渣的本愿
    洛谷P3709 大爷的字符串
    CF747F Igor and Interesting Numbers
    洛谷P1494 小Z的袜子
    洛谷P3396 哈希冲突
    分块⑨题
    洛谷P4219 大融合
    bzoj2959 长跑
    洛谷P2486 染色
    洛谷P4382 劈配
  • 原文地址:https://www.cnblogs.com/aerer/p/9931037.html
Copyright © 2011-2022 走看看