zoukankan      html  css  js  c++  java
  • hdu1272 小希的迷宫

    小希的迷宫

    http://acm.hdu.edu.cn/showproblem.php?pid=1272

    Problem Description
    上 次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房 间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走 了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从 5到达8。
     


    Input
    输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
    整个文件以两个-1结尾。
     


    Output
    对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
     


    Sample Input
    6 8  5 3  5 2  6 4  5 6  0 0
    8 1  7 3  6 2  8 9  7 5  7 4  7 8  7 6  0 0
    3 8  6 8  6 4  5 3  5 6  5 2  0 0
    -1 -1
     


    Sample Output
    Yes
    Yes
    No
    主要判断
    1.  边数=点数-1
    2.  是否连通
    3.  当输入的是 0 0 时候,输出时Yes
    #include<iostream>
    #include<string.h>
    #include<stdio.h>
    using namespace std;
    int father[101000],p[101000];
    void Make(int x)
    {
        father[x]=x;
    }
    int find(int x)
    {
        int r=x,t;
        while(r!=father[r])
        {
            r=father[r];
        }
        while(x!=r)
        {
            t=father[x];
            father[x]=r;
            x=father[x];
        }
        return r;
    }
    void Union(int a,int b)
    {
        a=find(a);
        b=find(b);
        if(a!=b)
            father[a]=b;
    }
    int main()
    {
        int a,b,sum,i,j,sum2,time=1;
        while(cin>>a>>b)
        {
            if(a==0&&b==0)
            {
                 cout<<"Yes"<<endl;
                 continue;
            }
               
            for(i=1;i<=100000;i++)
                Make(i);
            sum=sum2=0;
            memset(p,0,sizeof(p));
            if(a==-1&&b==-1)
            break;
            sum++;
            p[a]=1;p[b]=1;
            Union(a,b);
            while(cin>>a>>b)
            {
                if(a==0&&b==0)
                    break;
                p[a]=1;p[b]=1;
                Union(a,b);
                sum++;
            }
             getchar();getchar();
             for(i=0;i<=100000;i++)
                if(p[i]!=0)
                    sum2++;
              if(sum!=sum2-1)
                cout<<"No"<<endl;
             else
             {
                 int t,k=0;
                 for(i=1;i<=100000;i++)
                    if(p[i]!=0)
                    {
                     t=find(i);
                     break;
                    }
                    for(i=1;i<=100000;i++)
                    if(p[i]!=0)
                    {
                        if(find(i)!=t)
                        {
                            cout<<"No"<<endl;
                            k=1;
                            break;
                        }
                    }
                    if(k==0)
                        cout<<"Yes"<<endl;
             }
        }
    }
    View Code
  • 相关阅读:
    vlan原理与配置
    路由协议-ospf
    路由协议-rip
    人品
    阿波罗礼赞
    跳石头
    FBI树
    方程求解
    循环比赛
    国王的游戏
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3217400.html
Copyright © 2011-2022 走看看