zoukankan      html  css  js  c++  java
  • PAT 甲级 1037 Magic Coupon (25 分) (较简单,贪心)

    1037 Magic Coupon (25 分)
     

    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons { 1 2 4 − }, and a set of product values { 7 6 − − } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons NC​​, followed by a line with NC​​ coupon integers. Then the next line contains the number of products NP​​, followed by a line with NP​​ product values. Here 1, and it is guaranteed that all the numbers will not exceed 230​​.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:

    4
    1 2 4 -1
    4
    7 6 -2 -3
    

    Sample Output:

    43

    题意:

    给出两个集合,从这两个集合里面选出数量相同的元素进行一对一相乘,求能够得到的最大乘积之和。

    题解:

    对每个集合,将正数和负数分开考虑,将每个集合里的整数从大到小排序;将每个集合里的负数从小到大排序,然后同位置的正数与正数相乘,负数与负数相乘。

    注意点:

    输入为0的不要管,直接忽略,否则测试点1过不去

    AC代码:

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    ll na[100005];
    ll pa[100005];
    ll nb[100005];
    ll pb[100005];
    int kna=0,kpa=0,knb=0,kpb=0;
    int n1,n2;
    bool cmp(ll x, ll y){
        return x>y;
    }
    ll s=0;
    int main(){
        cin>>n1;
        ll x;
        for(int i=1;i<=n1;i++){
            cin>>x;
            if(x>0){
                pa[++kpa]=x;
            }else if(x<0){//=0的不要管 
                na[++kna]=x;
            }
        }
        cin>>n2;
        for(int i=1;i<=n2;i++){
            cin>>x;
            if(x>0){
                pb[++kpb]=x;
            }else if(x<0){//=0的不要管 
                nb[++knb]=x;
            }
        }
        sort(pa+1,pa+1+kpa,cmp);
        sort(pb+1,pb+1+kpb,cmp);
        sort(na+1,na+1+kna);
        sort(nb+1,nb+1+knb);
        int min_l=min(kpa,kpb);
        for(int i=1;i<=min_l;i++){
            s+=pa[i]*pb[i];
        }
        min_l=min(kna,knb);
        for(int i=1;i<=min_l;i++){
            s+=na[i]*nb[i];
        }
        cout<<s<<endl;
        return 0;
    }
  • 相关阅读:
    POJ
    POJ-2253 Frogger(最短路)
    背包问题(转自背包九讲+对应题目)
    POJ-1860 Currency Exchange (最短路)
    Bellman-Ford 最短路径算法
    POJ-3295 Tautology (构造)
    POJ-2586 Y2K Accounting Bug 贪心
    POJ 2965 The Pilots Brothers' refrigerator (暴力枚举)
    python(pymysql操作数据库)
    python复习概念__oop中
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11430318.html
Copyright © 2011-2022 走看看