zoukankan      html  css  js  c++  java
  • PAT 甲级1003 Emergency (25)(25 分)(Dikjstra,也可以自己到自己!)

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1

    Sample Output

    2 4

    1003.突发事件(25)

    作为一个城市紧急援救队的指挥者,你得到了一个国家的特殊地图。地图上分散着几座城市,城市间用道路连接着。每个城市援救队的数量以及两座城市之间每条道路的长度已经在地图上标出。当某些城市发生了突发事件,需要你的帮助时,你的工作是带领你的队伍尽快的赶到事发现场,与此同时,召集尽可能多的在路上的队伍。

    输入

    每个输入文件包含一个测试实例。每个实例的第一行有四个正整数:N(<= 500)是城市的个数(城市的编号从0到N-1),M是道路的个数,C1和C2分别是你现在所在的城市以及你必须去救援的城市。下一行有N个整数,第i个整数是第i个城市中救援队的数量。然后下面有M行,每行表示一条道路。每一行有三个整数c1,c2和L,分别表示道路连接的两个城市以及道路的长度。保证C1到C2之间存在至少一条路径。

    输出

    对于每个测试实例,在一行中输出两个数字:C1和C2之间不同的最短路径的个数,你能聚集起来的最多的救援队数量。

    一行中的所有数字必须被一个空格分隔开,在每行的结尾不允许出现空格。

    题解:

    本题我用了Dijstra,你可以什么都别管先打个Dijstra模版。

    然后考虑最短路条数:

      一开始,和C1相连的所有点的最短路数初始化为1,包括C1(可能自己到自己),其它初始化为0,。

      当d[k]+e[k][j]<d[j](通过k可以对C1到 j 可以更新)时,ti[j]=ti[k],(ti[p]表示C1到p的最短路条数),因为既然更新,肯定直接可以把原来的ti【j】覆盖了

      当 d[k]+e[k][j]==d[j],ti[j]+=ti[k];条数就可以增加了,但不是+1,是加上ti[k]。

    然后考虑人数最多:

      一开始,我只初试化了C1:rm[c1]=r[c1];C1的人数最多的就是为r[c1]。

      之后Dijstra每挑选出一个k都检查一下:rm[k]=max(rm[k],r[k]+r[s]);

      当d[k]+e[k][j]<d[j],rm[j]=rm[k]+r[j];

      当d[k]+e[k][j]==d[j],rm[j]=max(rm[j],rm[k]+r[j]);

    与第二组测试数据类似,我被卡的样例:

    3 2 1 1
    0 1 2
    0 1 1
    1 2 1

    应该为1 1

    #include<iostream>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<cmath>
    #include<queue>
    #define inf 0x3f3f3f3f
    using namespace std;
    int e[505][505];
    int ti[505];
    int r[505];
    int rm[505];
    int v[505];
    int d[505];
    int n,m;
    int c1,c2;
    int ss=0;
    void dijstra(int s)
    {
        for(int i=1;i<=n;i++) d[i]=e[s][i];
        d[s]=0;
        v[s]=1;
        while(1)
        {
            int mm=inf;
            int k=-1;
            for(int i=1;i<=n;i++)
            {
                if(!v[i]&&mm>d[i])
                {
                    k=i;
                    mm=d[i];
                }
            }
            if(k==-1) break;
            v[k]=1;
            rm[k]=max(rm[k],r[k]+r[s]);
            for(int j=1;j<=n;j++)
            {
                if(d[k]+e[k][j]<d[j])
                {
                    d[j]=d[k]+e[k][j];
                    ti[j]=ti[k];
                    rm[j]=rm[k]+r[j];
                }
                else if(d[k]+e[k][j]==d[j])
                {
                    ti[j]+=ti[k];
                    rm[j]=max(rm[j],rm[k]+r[j]);
                }
            }
        }
    }
    int main()
    {
        while(cin>>n>>m>>c1>>c2)
        {
            c1++;
            c2++;
            memset(e,inf,sizeof(e));
            memset(ti,0,sizeof(ti));
            memset(v,0,sizeof(v));
            memset(rm,0,sizeof(rm));
            ss=0;
            for(int i=1;i<=n;i++)
            {
                cin>>r[i];
            }
            for(int i=1;i<=m;i++)
            {
                int x,y,z;
                cin>>x>>y>>z;
                x++;
                y++;
                if(e[x][y]&&x==c1||y==c1)
                {
                    if(x==c1)
                        ti[y]++;
                    else ti[x]++;
                }
    
                if(e[x][y]>z)
                    e[x][y]=e[y][x]=z;
            }
            rm[c1]=r[c1];
            ti[c1]=1;
            dijstra(c1);
            cout<<ti[c2]<<" "<<rm[c2]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    信息学奥赛一本通(C++)在线评测系统——基础(一)C++语言——1100:金币
    信息学奥赛一本通(C++)在线评测系统——基础(一)C++语言——1100:金币
    信息学奥赛一本通(C++)在线评测系统——基础(一)C++语言——1100:金币
    windows下配置nginx
    python中对cookie进行添加、更新和删除
    xpathhelper使用
    xpathhelper 插件下载
    UvaLive7362 Fare(欧拉函数)
    UVaLive6834 Shopping
    UVa11384
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/9442367.html
Copyright © 2011-2022 走看看