zoukankan      html  css  js  c++  java
  • 1006 Sign In and Sign Out (25)(25 分)思路:普通的时间比较题。。。

    1006 Sign In and Sign Out (25)(25 分)

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40

    Sample Output:

    SC3021234 CS301133
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<cmath>
    #include<queue>
    #include<map>
    #include<vector>
    #include<stack>
    #define inf 0x3f3f3f3f
    using namespace std;
    int compare(int x,int y,int z,int a,int b,int c)
    {
        if(x==a)
        {
            if(y==b)
            {
                if(z>=c)
                    return 0;
                else return 1;
            }
            else if(y>b)
                return 0;
            else return 1;
        }
        else if(x>a)
            return 0;
        else 
            return 1;
    }
    
    int main()
    {
        int n;
        while(cin>>n)
        {
            string mi,ma;
            int ai=99,bi=99,ci=99;
            int aa=0,ba=0,ca=0;
            for(int i=1;i<=n;i++)
            {
                string s;
                cin>>s;
                int a,b,c;
                scanf("%d:%d:%d",&a,&b,&c);
                if(compare(ai,bi,ci,a,b,c)==0)
                {
                    mi=s;
                    ai=a;
                    bi=b;
                    ci=c;
                }
                scanf("%d:%d:%d",&a,&b,&c);
                if(compare(aa,ba,ca,a,b,c)==1)
                {
                    ma=s;
                    aa=a;
                    ba=b;
                    ca=c;
                }
            }
            cout<<mi<<" "<<ma;
        }
        return 0;
    }
        
     
  • 相关阅读:
    关于树论【动态树问题(LCT)】
    caioj1462: 【EXKMP】回文串
    Node.js 文件上传 cli tools
    VuePress & Markdown Slot
    npm config set registry
    Front End Frameworks Trending 2021
    如何使用 VuePress 搭建一个 element-ui 风格的文档网站
    Semantic Pull Requests All In One
    [POJ2559]Largest Rectangle in a Histogram
    [POJ3253]Fence Repair
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/9449859.html
Copyright © 2011-2022 走看看