zoukankan      html  css  js  c++  java
  • hdu 1007(分治法)

    用半分治法做的. 很在把一堆分成两堆后,递归求得这两堆的最小距离后,关键就是求两堆之间的距离是否会更小,然后用一些优化就可以过这题. 

    下次试试算法导论上的方法,应该会稳定些,感觉这方法还是很坑的, 可以有数据克.  不过要弄出这种数据也难.

    还有感觉分治法,和归并排序很相似.

    Quoit Design

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 15345    Accepted Submission(s): 3814


    Problem Description
    Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
    In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

    Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
     
    Input
    The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
     
    Output
    For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
     
    Sample Input
    2
    0 0
    1 1
    2
    1 1
    1 1
    3
    -1.5 0
    0 0
    0 1.5
    0
     
    Sample Output
    0.71
    0.00
    0.75
     
    Author
    CHEN, Yue
     
    Source
     
    Recommend
    JGShining
     
    #include <stdio.h>
    #include <string.h>
    #include <math.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    #define N 100100
    
    struct node
    {
        double x,y;
    }g[N];
    
    node save[N];
    
    int cmp(node t,node t1)
    {
        return t.x<t1.x;
    }
    
    int cmp1(node t,node t1)
    {
        return t.y<t1.y;
    }
    double cal(node t,node t1)
    {
        return sqrt((t.x-t1.x)*(t.x-t1.x)+(t.y-t1.y)*(t.y-t1.y));
    }
    
    double fuc(int b,int d)
    {
        if(d-b==1) return cal(g[b],g[d]);
        if(d-b==2) 
        {
            return min(cal(g[b],g[b+1]),min( cal(g[b],g[d]),cal(g[b+1],g[d])));
        }
        int mid=(b+d)/2;
        double mi=min(fuc(b,mid),fuc(mid+1,d));
        for(int i=mid-1;i>=b;i--)
        {
            if(g[mid].x-g[i].x>mi)
            {
                b=i;
                break;
            }
        }
        for(int i=mid;i<=d;i++)
        {
            if(g[i].x-g[mid-1].x>mi)
            {
                d=i;
                break;
            }
        }
        int cnt=0;
        for(int i=b;i<=d;i++)
            save[cnt++]=g[i];
        sort(save,save+cnt,cmp1);
        for(int i=0;i<cnt;i++)
            for(int j=i+1;j<cnt;j++)
            {
                if(save[j].y-save[i].y>mi) break; // 这步优化很是重要
                if(cal(save[i],save[j])<mi) mi=cal(save[i],save[j]);
            }
        return mi;
    }
    
    int main()
    {
        int n;
        while(scanf("%d",&n)&&n)
        {
            for(int i=0;i<n;i++)
            {
                scanf("%lf%lf",&g[i].x,&g[i].y);
            }
            sort(g,g+n,cmp);
            printf("%.2lf\n",fuc(0,n-1)/2);
        }
        return 0;
    } 
  • 相关阅读:
    sqlite数据库的char,varchar,text,nchar,nvarchar,ntext的区别(转)
    DELPHI XE5-8 弹出列表框供选择
    delphi弹出选择对话框选择目录|SelectDirectory 函数(转)
    php 与java安卓客户端的查询交互
    sql查询语句的拼接小技巧(高手勿喷)
    高德地图应用——与云图后台交互
    Inno Setup 通用脚本及简要说明( 一般情况够用了)
    不用SQL给打印记录编号
    DELPHI XE5/6/7 android 无线真机调试
    超级简单的例子说明JAVA PACKET CLASS 和变量之间的关系
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/2913051.html
Copyright © 2011-2022 走看看