zoukankan      html  css  js  c++  java
  • POJ 2965

    The Pilots Brothers' refrigerator
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 16008   Accepted: 6035   Special Judge

    Description

    The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

    There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

    The task is to determine the minimum number of handle switching necessary to open the refrigerator.

    Input

    The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

    Output

    The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

    Sample Input

    -+--
    ----
    ----
    -+--

    Sample Output

    6
    1 1
    1 3
    1 4
    4 1
    4 3
    4 4

    AC代码如下(枚举+BFS),不是很快,勉强能够交上:


    //1936K	938MS
    #include <iostream>
    #include <queue>
    #include <vector>
    using namespace std;
    static const int  ROW_COL_NUM = 4;
    static const int  GRID_NUM = ROW_COL_NUM * ROW_COL_NUM ;
    static const int MAX_STATES = 1 << GRID_NUM ;
    int isVisit[MAX_STATES] ; //是否被访问, 0表示没有,否则表示是在经过了几次操作之后访问到的
    
    typedef struct node 
    {
    	int state; //当前状态
    	int pre ;
    	int loc ;
    	node(int s, int p, int l) : state(s), pre(p), loc(l) {} ;
    	node(int s): state(s){pre = -1 ; } ;
    
    }stateNode;
    
    
    bool isOpened(int state)
    {
    	if (state == 0) return true ;
    	return false ;
    }
    
    int switchState(int state, int i)
    {
    	state ^= (1 << i) ;
    	int tmp = i - 4 ;
    	while(tmp >= 0)
    	{
    		state ^= (1 << tmp) ;
    		tmp -= 4 ;
    	}
    	tmp = i + 4 ;
    	while (tmp < GRID_NUM)
    	{
    		state ^= (1 << tmp) ;
    		tmp += 4 ;
    	}
    
    	tmp = i ;
    	while(tmp % ROW_COL_NUM != 0)
    	{
    		tmp -= 1 ;
    		state ^= (1 << tmp) ;
    	}
    	tmp = i ;
    	while(tmp % ROW_COL_NUM != 3)
    	{
    		tmp += 1 ;
    		state ^= (1 << tmp) ;
    	}
    	return state ;
    }
    
    int buildState()
    {
    	int ret = 0 ;
    	char ch ;
    	for (int i = 0; i < GRID_NUM ; ++ i)
    	{
    		cin >> ch ;
    		if (ch == '+')
    			ret += (1 << i) ;
    	}
    	return ret ;
    }
    
    
    void bfs(int initState)
    {
    	memset(isVisit, 0 , sizeof(isVisit)) ;
    
    	vector<stateNode> statesQueue ;
    	int qIndex = 0 ;
    	statesQueue.push_back(stateNode(initState)) ;
    
    	while(!statesQueue.empty())
    	{
    		stateNode curState = statesQueue.at(qIndex) ;
    		qIndex ++ ;
    
    		for (int i = 0; i < GRID_NUM; ++ i)
    		{
    			int nextState = switchState(curState.state, i) ;
    			if (isVisit[nextState] == 0)
    			{
    				isVisit[nextState] = isVisit[curState.state] + 1 ;
    				stateNode addNode = stateNode(nextState, qIndex - 1, i) ;
    
    				if (isOpened(nextState)) //找到结果
    				{
    					cout << isVisit[nextState] << endl;
    					while(addNode.pre != -1) //打印路径
    					{
    						cout << addNode.loc/4 + 1<< " " << addNode.loc % 4 + 1<< endl;
    						addNode = statesQueue.at(addNode.pre) ;
    					}
    					return ;
    				}
    				statesQueue.push_back(addNode) ;
    			}
    		}
    	}
    }
    
    int main(int argc, char** argv)
    {
    	int initValue = buildState() ;
    	bfs(initValue) ;
    	return 0 ;
    }



  • 相关阅读:
    面向对象SOLID原则-设计模式-第2篇
    python 设计模式 开篇 第1篇
    区块链 第1篇 什么是区块链 区块链与比特币的关系 区块链的发展历史 应用领域
    HTTP协议六种请求:GET,HEAD,PUT,DELETE,POST
    python垃圾回收机制
    类的MRO属性 C3算法
    Vue第六篇 element-ui 项目管理工具npm webpack 启Vue项目vue-cli
    《EffctiveJava》泛型
    Kafka总结
    Windows 关闭端口号
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405187.html
Copyright © 2011-2022 走看看