代码改变世界
[登录 · 注册]
  • Error:Could not determine the classpath for interface com.android.builder.model.AndroidProject.
  • Android Studio导入Eclipse项目报错Error:Could not determine the class-path for interface com.android.builder.model.AndroidProject.的解决办法

    错误原因:

    因为Eclipse所使用的ADT插件已经不再更新,所以从Eclipse导出的项目使用的是旧版本Gradle插件,而新版的Android Studio(v2.3+)已经不再支持1.0.0版本以下的Gradle插件,因此报错。 
    相应的解决办法就是将配置文件中的Gradle插件版本改成本地已经安装的版本。

    解决步骤

    1、查看本地安装了哪个版本的Gradle Build Tool

    打开Android Studio的安装目录,注意不是SDK安装目录或项目文件所在目录。在Android Studio的安装目录中,找到以下文件夹: 
    gradlem2repositorycomandroid oolsuildgradle 
    在最后的这个gradle文件夹中,可以看到本机已经安装了哪些版本的Gradle插件。如图: 

    2、修改项目配置文件

    打开Android Studio,在左侧导航栏中打开Project窗口,选择Android选项卡,点开其中的Gradle Scripts,找到项目的配置文件build.gradle(Module:xxx),打开该文件可以看到,文件中classpath的配置被标红。如图: 

    classpath配置中的Gradle插件版本改为本机已将安装的版本,然后保存。如图: 

    3、(可选)更改项目所用的Gradle版本

    注意这里更改的是Gradle版本,不是Gradle插件版本。虽然不是必须修改,但最好还是修改成Android Studio默认使用的最新版,不然有可能出现错误:

    A problem occurred evaluating root project 'XXX'.
    > org/gradle/initialization/BuildCompletionListener
    • 1
    • 2

    首先查看本地已经有了哪些版本的Gradle。在文件夹C:Users你的用户名.gradlewrapperdists中可以看到本机已经安装了哪些版本的Gradle。如图: 

    然后打开Android Studio,再到左侧边栏打开Project视图,选择Android选项卡,点开其中的Gradle Scripts,打开文件gradle-wrapper.properties,将文件中最后一行中的gradle-x.x-all中的版本改成本机中已经安装的最新的Gradle版本。如图,将1.12改成3.3: 

    4、重新编译项目

     大功告成。

  • 【推广】 阿里云小站-上云优惠聚集地(新老客户同享)更有每天限时秒杀!
    【推广】 云服务器低至0.95折 1核2G ECS云服务器8.1元/月
    【推广】 阿里云老用户升级四重礼遇享6.5折限时折扣!
  • 原文:https://www.cnblogs.com/diyishijian/p/7729034.html
Copyright 2008-2020 晋ICP备12007731号-1