zoukankan      html  css  js  c++  java
  • NYOJ150 Train Problem I

     

    Train Problem I

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:1
     
    描述
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    输入
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
    输出
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
    样例输入
    3 123 321
    3 123 312
    
    样例输出
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    第一次用STL,代码如下:
    //STL栈操作
    #include<iostream>
    #include<cstring>
    #include<stack>
    using namespace std;
    int main()
    {
    	int num,i,j,k,flag[20];
    	stack <char> s;
    	char s1[10],s2[10];
    	while(cin>>num)
    	{
    		memset(flag,-1,sizeof(flag));
    		cin>>s1>>s2;
    		j=k=0;
    		for(i=0;i<num;++i)
    		{
    			s.push(s1[i]);
    			flag[k++]=1;//1表示IN
    			while(!s.empty()&&s.top()==s2[j])
    			{
    				flag[k++]=0;//0表示OUT
    				s.pop();
    				++j;//此处不能加到while后边的括号里边,可能是优先级问题
    			}	
    		}
    		if(j==num)
    		{
    			cout<<"Yes.\n";
    			for(i=0;i<k;++i)
    			{
    				if(flag[i])
    					cout<<"in\n";
    				else
    					cout<<"out\n";
    			}
    			cout<<"FINISH\n";
    		}
    		else
    			cout<<"No.\nFINISH\n";
    	}
    	return 0;
    }
    
    功不成,身已退
  • 相关阅读:
    爬楼梯
    字母异位词分组
    发射子弹过程
    删除元素
    删除排序数组中的重复项
    JAVA编程-------------9、查找1000以内的完数
    JAVA-------------8、计算a+aa+aaa+.....
    JAVA编程----------7、统计一段字符串中的英语字母数,空格数,数字和其他字符数
    JAVA编程---------6、最大公约数和最小公倍数
    JAVA编程----------5、利用条件运算符的嵌套来完成:成绩>=90(A) 60-89(B) 60分以下(C)
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2601421.html
Copyright © 2011-2022 走看看