zoukankan      html  css  js  c++  java
  • BZOJ 3942: [Usaco2015 Feb]Censoring

    Description

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

    FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

    Please help FJ determine the final contents of S after censoring is complete

    有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

    Input

    The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
     

    Output

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

    Sample Input

    whatthemomooofun
    moo

    Sample Output

    whatthefun

    Solution:

      本题KMP+栈模拟。

      首先求出模式串的next数组,再在主串中去匹配,匹配的同时记录答案并用栈维护当前位的模式串指针$p$,然后若在第$i$位匹配到了模式串,则将模式串指针回到栈中维护的第$i-m$个的指针位置,继续匹配,重复此过程,最后输出答案就好了。

    代码:

    #include<bits/stdc++.h>
    #define il inline
    #define ll long long
    #define For(i,a,b) for(int (i)=(a);(i)<=(b);(i)++)
    #define Bor(i,a,b) for(int (i)=(b);(i)>=(a);(i)--)
    using namespace std;
    const int N=1000005;
    int n,m,top,now,f[N],stk[N];
    char s[N],t[N],ans[N];
    
    int main(){
        scanf("%s%s",t,s),n=strlen(t),m=strlen(s);
        int p=0;
        For(i,1,m-1){
            while(p&&s[i]!=s[p]) p=f[p];
            if(s[i]==s[p]) f[i+1]=(++p);
            else f[i+1]=0;
        }
        p=0;
        For(i,0,n-1){
            ans[++top]=t[i];
            while(p&&ans[top]!=s[p]) p=f[p];
            if(s[p]==ans[top]) p++;
            if(p==m) top-=m,p=stk[top];
            else stk[top]=p;
        }
        For(i,1,top) printf("%c",ans[i]);
        return 0;
    }
  • 相关阅读:
    Twitter Storm安装配置(Ubuntu系统)单机版
    Ubuntu下安装配置JDK1.7
    JS性能优化
    JavaScript禁用页面刷新
    pomelo获取客户端IP
    MySQL数据库工具类之——DataTable批量加入MySQL数据库(Net版)
    MySQL5.6忘记root密码(win平台)
    清空文件下的SVN控制文件
    Windows平台搭建NodeJs开发环境以及HelloWorld展示—图解
    Unity3D默认的快捷键
  • 原文地址:https://www.cnblogs.com/five20/p/9473394.html
Copyright © 2011-2022 走看看