zoukankan      html  css  js  c++  java
  • sdnu 1319.Russian Roulette

    1319.Russian Roulette

    Time Limit: 1000 MS    Memory Limit: 32768 KB
    Total Submission(s): 84    Accepted Submission(s): 23

    Description

    You have a revolver gun with a cylinder that has n chambers. Chambers are located in a circle on a cylinder. Each chamber can be empty or can contain a round. One chamber is aligned with the gun's barrel. When trigger of the gun is pulled, the gun's cylinder rotates, aligning the next chamber with the barrel, hammer strikes the round, making a shot by firing a bullet through the barrel. If the chamber is empty when the hammer strikes it, then there is no shot but just a ``click".

    You have found a use for this gun. You are playing Russian Roulette with your friend. Your friend loads rounds into some chambers, randomly rotates the cylinder, aligning a random chamber with a gun's barrel, puts the gun to his head and pulls the trigger. You hear ``click" and nothing else -- the chamber was empty and the gun did not shoot.

    Now it is your turn to put the gun to your head and pull the trigger. You have a choice. You can either pull the trigger right away or you can randomly rotate the gun's cylinder and then pull the trigger. What should you choose to maximize the chances of your survival?

    Input

    The input file contains several datasets. A dataset contains a single line with a string of n digits ``0" and ``1" ( 2<=n<=100). This line of digits represents the pattern of rounds that were loaded into the gun's chambers. ``0" represent an empty chamber, ``1" represent a loaded one. In this representation, when cylinder rotates before a shot, the next chamber to the right gets aligned with the barrel for a shot. Since the chambers are actually located on a circle, the first chamber in this string follows the last one. There is at least one ``0" in this string.

    Output

    For each dataset, write to the output file one of the following words (without quotes):
    • ``SHOOT" -- if pulling the trigger right away makes you less likely to be actually shot in the head with the bullet (more likely that the chamber will be empty).
    • ``ROTATE" -- if randomly rotating the cylinder before pulling the trigger makes you less likely to be actually shot in the head with the bullet (more likely that the chamber will be empty).
    • ``EQUAL" -- if both of the above choices are equal in terms of probability of being shot.

    Sample Input

    0011
    0111
    000111
    

    Sample Output

    EQUAL
    ROTATE
    SHOOT

    Source

    Unknown
    他的朋友先开了一枪 但是没死 所以应该比较(0的个数/总枪子数)与(00/00+01)的关系
    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
        string s;
        while(cin>>s)
        {
            int ans1=0;
            int ans2=0;
            int ans3=0;
            int ans4=0;
            ans2=s.length();
            for(int i=0;i<s.length();i++)
            {
                if(s[i]=='0')
                {
                    ++ans1;
                }
            }
            s=s[s.length()-1]+s;
            for(int i=0;i<s.length()-1;i++)
            {
                if(s[i]=='0'&&s[i+1]=='0')
                {
                    ++ans3;
                    ++ans4;
                }
                else if(s[i]=='0'&&s[i+1]=='1')
                {
                    ++ans4;
                }
            }
    //        cout<<s<<' '<<ans1<<'/'<<ans2<<' '<<ans3<<'/'<<ans4<<endl;
            if(ans1*ans4<ans2*ans3)
            {
                cout<<"SHOOT"<<endl;
            }
            else if(ans1*ans4==ans2*ans3)
            {
                cout<<"EQUAL"<<endl;
            }
            else
            {
                cout<<"ROTATE"<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    Java 8 stream的详细用法
    SpringBoot启动异常 Process finished with exit code 1
    GIT-版本管理-初阶使用
    升级 kubeadm 集群
    antdv 获取 axios文件上传实时进度
    Ant Design Vue 实现文件上传 (通过点击提交按钮后开始上传)
    Ant Design Vue 实现菜单栏根据url变化自动高亮和展开
    Do not access Object.prototype method 'hasOwnProperty' from target object
    Nginx配置WebSocket (包含nginx-ingress-controller)
    Django ORM 常用字段和参数/关系字段/ForeignKey操作/数据库查询优化(重要)/事务初识
  • 原文地址:https://www.cnblogs.com/guanwen769aaaa/p/11224041.html
Copyright © 2011-2022 走看看