zoukankan      html  css  js  c++  java
  • hdu 2955

    Robberies

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4531    Accepted Submission(s): 1713


    Problem Description
    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     
    Input
    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     
    Output
    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

    Notes and Constraints
    0 < T <= 100
    0.0 <= P <= 1.0
    0 < N <= 100
    0 < Mj <= 100
    0.0 <= Pj <= 1.0
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     
    Sample Input
    3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
     
    Sample Output
    2 4 6
    #include<iostream>
    double  b[10010];
    using namespace
    std;
    struct
    node
    {

        int
    q;
        double
    v;
    }
    a[110];
    double
    max(double a,double b)
    {

        if
    (a>b)
            return
    a;
        else
            return
    b;
    }

    int
    main()
    {

        int
    i,j,sum,n,m,count;
        double
    l;
        while
    (~scanf("%d",&n))
        {

            while
    (n--)
            {

                l=0,sum=0;
                scanf("%lf%d",&l,&m);
                for
    (i=1;i<=m;i++)
                {

                    scanf("%d%lf",&a[i].q,&a[i].v);
                    sum+=a[i].q;
                }

                memset(b,0,sizeof(b));
                b[0]=1;
                for
    (i=1;i<=m;i++)
                {

                    for
    (j=sum;j>=a[i].q;j--)
                        b[j]=max(b[j],b[j-a[i].q]*(1-a[i].v));
                }

                for
    (count=sum;count>=0;count--)
                {

                    if
    (b[count]>=(1-l))//求最大的能偷到的数目
                    {
                        printf("%d\n",count);
                        break
    ;
                    }
                }
            }
        }

        return
    0;
    }
     
  • 相关阅读:
    ArrayList和LinkedList比较
    高度最小的BST
    Linux查看网络即时网速
    UISegmentedControl判断点击第几项
    ant关于发邮件报错535 Error:authentication failed解决方法
    Selenium WebDriver下载地址
    GitLab服务器IP地址修改
    jenkins+gitlab自动化构建
    GitLab默认密码
    jenkins全局安全配置-授权策略,误操作将设置为遗留模式,导致无全部管理员权限,修改config.xml的<authorizationStrategy 为以下
  • 原文地址:https://www.cnblogs.com/hduacm/p/2623349.html
Copyright © 2011-2022 走看看