zoukankan      html  css  js  c++  java
  • [ACM] POJ 3273 Monthly Expense (二分解决最小化最大值)

    Monthly Expense
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 14158   Accepted: 5697

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5
    100
    400
    300
    100
    500
    101
    400

    Sample Output

    500

    Hint

    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

    Source


    解题思路:

    题意为给定一个n个数组成的序列,划分为m个连续的区间,每一个区间全部元素相加,得到m个和,m个和里面肯定有一个最大值,我们要求这个最大值尽可能的小。

    用二分查找能够非常好的解决问题。这类问题的框架为,找出下界left和上界right, while(left< right), 求出mid,看这个mid值是符合题意,继续二分。最后right即为答案。

    本题中的下界为n个数中的最大值,由于这时候,是要划分为n个区间(即一个数一个区间),left是满足题意的n个区间和的最大值,上届为全部区间的和,由于这时候,是要划分为1个区间(全部的数都在一个区间里面),    1<=m<=n, 所以我们所要求的值肯定在 [left, right] 之间。对于每个mid,遍历一遍n个数,看能划分为几个区间,假设划分的区间小于(或等于)给定的m,说明上界取大了, 那么 另 right=mid,否则另 left=mid+1.

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    const int maxn=100010;
    int money[maxn];
    int n,m;
    
    int main()
    {
        scanf("%d%d",&n,&m);
        int left=-1,right=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&money[i]);
            if(left<money[i])
                left=money[i];
            right+=money[i];
        }
        while(left<right)
        {
            int mid=(left+right)/2;
            int cnt=0;
            int cost=0;
            for(int i=1;i<=n;i++)
            {
                if(cost+money[i]>mid)
                {
                    cnt++;//划分区间,不包含当前的money[i]
                    cost=money[i];
                }
                else
                    cost+=money[i];
            }
            cnt++;//最后一个cost值也要占一天
            if(cnt<=m)
                right=mid;
            else
                left=mid+1;
        }
        cout<<right<<endl;
        return 0;
    }
    



  • 相关阅读:
    [Java123] 方法重载中遇到的编译器错误: both methods have same erasure => 引入Java泛型type erasure
    [Java123] 认识JavaBean
    [Java123] HashMap实现和应用
    [Java123] 开源工具guava比较器链ComparisonChain (附加比较null空值的实现方法)
    [Java123] Java的异常处理机制
    [ORACLE123] sysdate处理
    Linux进程实时可视化监控
    【Java123】ThreadLocal学习笔记
    【XML123】了解XMLUnit
    字符串%s
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/3902914.html
Copyright © 2011-2022 走看看