zoukankan      html  css  js  c++  java
  • HDU

    One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
    Kiddo: "I have an array A and a number k , if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?

    InputThe first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: ,n  A1,A2…An .
    1T20 1≤T≤20
    1n10 5  1≤n≤105
    0k0≤k≤n
    110 5  1≤Ai≤105
    OutputFor each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
    Sample Input

    3
    4 1
    1 4 3 7
    5 2
    4 1 3 1 2
    6 1
    1 4 3 5 4 6

    Sample Output

    A is a magic array.
    A is a magic array.
    A is not a magic array.
    #include<bits/stdc++.h>
    #define rep(i,a,b) for(int i=a;i<=b;i++)
    using namespace std;
    const int maxn=100010;
    int a[maxn],b[maxn];
    int main()
    {
        int T,N,K,cnt,pos;
        scanf("%d",&T);
        while(T--){
            scanf("%d%d",&N,&K);
            rep(i,1,N) scanf("%d",&a[i]);
            cnt=0;
            rep(i,1,N) pos=upper_bound(b+1,b+cnt+1,a[i])-b,b[pos]=a[i],cnt=max(pos,cnt);
            if(cnt+K>=N) puts("A is a magic array.");
            else {
                reverse(a+1,a+N+1);
                cnt=0;
                rep(i,1,N) pos=upper_bound(b+1,b+cnt+1,a[i])-b,b[pos]=a[i],cnt=max(pos,cnt);
                if(cnt+K>=N) puts("A is a magic array.");
                else puts("A is not a magic array.");
            }
        }
        return 0;
    }
  • 相关阅读:
    71)PHP,使用cookie的语法问题
    70)PHP,cookie的安全传输和HTTPonly
    69)PHP,cookie的有效域
    68)PHP,cookie的详细属性和有效期
    C#中的internal关键字
    C# 中如何将一个类文件(XX.CS)封装成.dll文件
    c# 委托和事件(总结篇)
    c#事件实例三
    c#事件实例二
    c#事件实例一
  • 原文地址:https://www.cnblogs.com/hua-dong/p/9814500.html
Copyright © 2011-2022 走看看