zoukankan      html  css  js  c++  java
  • NYOJ 308

     

    Substring

    时间限制:1000 ms | 内存限制:65535 KB
    难度:1
     
    描述

    You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.

    Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

     
    输入
    The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
    输出
    Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
    样例输入
    3                   
    ABCABA
    XYZ
    XCVCX
    
    样例输出
    ABA
    X
    XCVCX
    

    //利用最长连续公共子序列长度算法 
    #include<stdio.h>
    #include<string.h>
    int main()
    {
    	int T,i,j;int len,max,k;
    	char a[51],b[51],c[51][51];
    	scanf("%d%*c",&T);
    	while(T--)
    	{
    		memset(a,0,sizeof(a));
    		memset(b,0,sizeof(b));
    		memset(c,0,sizeof(c));
    		scanf("%s",a);
    		len=strlen(a);
    		for(i=len-1;i>=0;i--)
    			b[len-1-i]=a[i];
    		max=0;
    		for(i=1;i<=len;i++)
    			for(j=1;j<=len;j++)
    				if(a[i-1]==b[j-1])
    				{
    					c[i][j]=c[i-1][j-1]+1;
    					if(max<c[i][j])
    					{
    						max=c[i][j];
    						k=i;
    					}
    				}
    		/*max=c[len][len];,这条不行*/ 
    		for(i=k-max+1;i<=k;i++)
    			printf("%c",a[i-1]);
    		printf("\n");
    	}
    	return 0;
    }                
    
  • 相关阅读:
    spring冲刺第九天
    梦断代码读后感1
    spring冲刺第八天
    站立会议第三天
    站立会议第二天
    站立会议第一天
    购书问题
    团队项目NABCD分析
    你的灯亮着吗读书笔记3
    你的灯亮着吗读书笔记2
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2546235.html
Copyright © 2011-2022 走看看