zoukankan      html  css  js  c++  java
  • Wooden Sticks_贪心

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 18645    Accepted Submission(s): 7632


    Problem Description
    There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

    (a) The setup time for the first wooden stick is 1 minute. 
    (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

    You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
     
    Input
    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
     
    Output
    The output should contain the minimum setup time in minutes, one per line.
     
    Sample Input
    3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
     
    Sample Output
    2 1 3

    对木棍的长度和重量进行排序,以长度为首要考虑。排序完后的不一定都是下一根木棍重量和长度都大于前一根的。于是,我们对排序后的数组进行多次扫描,将可以在一次建立时间内完成的进行标记,知道木棍全部标记(设置一个外部变量来计数已扫描的元素的数量)。

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    struct stick
    {
        int l,w;
    }s[5000];
    bool cmp(stick a,stick b)
    {
        if(a.l<b.l) return true;
        else if(a.l>b.l) return false;
        else return a.w<b.w;
    }
    int main()
    {
        int t,n,minn,ti;
        int vis[5000];
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(int i=0;i<n;i++)
                cin>>s[i].l>>s[i].w;
            sort(s,s+n,cmp);
            memset(vis,0,sizeof(vis));
            int k=0;
            minn=0;
            int id;
            while(k!=n)
            {
                for(int i=0;i<n;i++)
                {
                    if(!vis[i])
                    {
                        id=i;
                        minn++;
                        break;
                    }
                }
                for(int i=0;i<n;i++)
                {
                    if(!vis[i]&&s[i].l>=s[id].l&&s[i].w>=s[id].w)
                    {
                        vis[i]=1;
                        k++;
                        id=i;
                    }
                }
            }
            cout<<minn<<endl;
        }
        return 0;
    }
  • 相关阅读:
    洛谷 1341 无序字母对
    POJ 2774 后缀数组 || 二分+哈希
    HDU 1251 统计难题
    【解题报告】AtCoder ABC115 (附英文题目)
    【模板】后缀数组
    洛谷 3567/BZOJ 3524 Couriers
    Beta 冲刺 (1/7)
    团队项目评测
    beta冲刺前准备
    Alpha冲刺——事后诸葛亮
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5765493.html
Copyright © 2011-2022 走看看