zoukankan      html  css  js  c++  java
  • HDU Number Sequence

    Number Sequence

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 930 Accepted Submission(s): 367
     
    Problem Description
    A number sequence is defined as follows:
    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
    Given A, B, and n, you are to calculate the value of f(n).
     
    Input
    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
     
    Output
    For each test case, print the value of f(n) on a single line.
     
    Sample Input
    1 1 3
    1 2 10
    0 0 0
     
    Sample Output
    2
    5
     
    Author
    CHEN, Shunbao
     
    Source
    ZJCPC2004
     
    Recommend
    JGShining

    对于公式 f[n] = A * f[n-1] + B * f[n-2]; 后者只有7 * 7 = 49 种可能,为什么这么说,因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过循环节出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以轻松解决了。

    #include<stdio.h>
    
    int a,b,n;
    int f[60];
    
    int main(){
        int i,j;
        int beg,end;
        f[0]=f[1]=f[2]=1;
        while(scanf("%d%d%d",&a,&b,&n)){
            if(a==0 && b==0 && n==0)
                break;
            int flag=0;
            for(i=3;i<=n;i++){
                f[i]=(a*f[i-1]+b*f[i-2])%7;
                for(j=2;j<i;j++){
                    if(f[i]==f[j] && f[i-1]==f[j-1]){
                        beg=j,end=i;
                        flag=1;
                        break;
                    }
                }
                if(flag)
                    break;
            }
            if(flag)
                printf("%d\n",f[beg+(n-end)%(end-beg)]);
            else
                printf("%d\n",f[n]);
        }
        return 0;
    }
  • 相关阅读:
    二叉树非递归先中后序遍历 及 非递归交换二叉树两个孩子的位置
    COM 学习小记录
    Linux 信号量 生产者消费者小例题
    打印数字 形状有点得味
    (链表)链表倒序
    C++ 数组名作为函数参数 都是我的错
    进程 线程
    《C++ Qt 设计模式》8|15拼图 小游戏的简单实现。拜托,别乱点!
    PMAC运动程序例程(一)
    中国获得2022年冬奥会举办权【经济学人】
  • 原文地址:https://www.cnblogs.com/jackge/p/2964403.html
Copyright © 2011-2022 走看看