zoukankan      html  css  js  c++  java
  • POJ 1195 Mobile phones (二维树状数组)

    Mobile phones
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 12238   Accepted: 5617

    Description

    Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

    Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

    Input

    The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

    The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

    Table size: 1 * 1 <= S * S <= 1024 * 1024 
    Cell value V at any time: 0 <= V <= 32767 
    Update amount: -32768 <= A <= 32767 
    No of instructions in input: 3 <= U <= 60002 
    Maximum number of phones in the whole table: M= 2^30 

    Output

    Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

    Sample Input

    0 4
    1 1 2 3
    2 0 0 2 2 
    1 1 1 2
    1 1 2 -1
    2 1 1 2 3 
    3
    

    Sample Output

    3
    4

    Source

    题意:讲的是在一个S*S的正方形内,有两种操作 
    1 X Y A 是在(X,Y)这个点加A
    2 X1 Y1 X2 Y2  查询(X1,Y1) 到 (X2,Y2) 这范围内手机的数量

    其中 开始是 0 s  表示有一个S*S的区域 3表示结束

    思路:简单的二维树状数组   ans = sum (x2+1,y2+1) - sum(x2+1,y1) - sum(x1,y2+1) + sum (x1,y1);

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=1050;
    
    int n,array[N][N];
    
    int lowbit(int x){
        return x&(-x);
    }
    
    void add(int i,int j,int w){
        int tmp;
        while(i<=n){
            tmp=j;
            while(tmp<=n){
                array[i][tmp]+=w;
                tmp+=lowbit(tmp);
            }
            i+=lowbit(i);
        }
    }
    
    int sum(int i,int j){
        int tmp,ans=0;
        while(i>0){
            tmp=j;
            while(tmp>0){
                ans+=array[i][tmp];
                tmp-=lowbit(tmp);
            }
            i-=lowbit(i);
        }
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int op,x1,y1,x2,y2,w;
        memset(array,0,sizeof(array));
        while(~scanf("%d",&op)){
            if(op==0){
                scanf("%d",&n);
                n++;
            }else if(op==1){
                scanf("%d%d%d",&x1,&y1,&w);
                add(x1+1,y1+1,w);
            }else if(op==2){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                int ans=sum(x2+1,y2+1)-sum(x1,y2+1)-sum(x2+1,y1)+sum(x1,y1);
                printf("%d\n",ans);
            }else if(op==3)
                break;
        }
        return 0;
    }
  • 相关阅读:
    慢sql
    drf 和django 字段参数解析
    django uwsgi
    django 中间件原理图和实现方法
    解决 控制台console导入模型报错 django.core.exceptions.ImproperlyConfigured: Requested setting INSTALLED_APPS, but settings are not configured.
    版本控制器 django全局和局部配置
    极客论坛Cpu瓶颈定位思路
    jmeter grpc 自定义开发java请求案例
    论文阅读笔记四十七:Generalized Intersection over Union: A Metric and A Loss for Bounding Box Regression(CVPR2019)
    论文阅读笔记四十六:Feature Selective Anchor-Free Module for Single-Shot Object Detection(CVPR2019)
  • 原文地址:https://www.cnblogs.com/jackge/p/3039403.html
Copyright © 2011-2022 走看看