zoukankan      html  css  js  c++  java
  • SDUT Greatest Number

    Greatest Number

    Time Limit: 1000MS Memory limit: 65536K

    题目描述

        Saya likes math, because she think math can make her cleverer.
        One day, Kudo invited a very simple game:
        Given N integers, then the players choose no more than four integers from them (can be repeated) and add them together. Finally, the one whose sum is the largest wins the game. It seems very simple, but there is one more condition: the sum shouldn’t larger than a number M.
        Saya is very interest in this game. She says that since the number of integers is finite, we can enumerate all the selecting and find the largest sum. Saya calls the largest sum Greatest Number (GN). After reflecting for a while, Saya declares that she found the GN and shows her answer.
        Kudo wants to know whether Saya’s answer is the best, so she comes to you for help.
        Can you help her to compute the GN?

    输入

        The input consists of several test cases.
        The first line of input in each test case contains two integers N (0<N1000) and M(0<M 1000000000), which represent the number of integers and the upper bound.
        Each of the next N lines contains the integers. (Not larger than 1000000000)
        The last case is followed by a line containing two zeros.

    输出

        For each case, print the case number (1, 2 …) and the GN.
        Your output format should imitate the sample output. Print a blank line after each test case.

    示例输入

    2 10
    100
    2
    
    0 0

    示例输出

    Case 1: 8

    提示

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    #include<algorithm>
    
    using namespace std;
    
    int n,m;
    int num[1000010];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int cases=0;
        while(~scanf("%d%d",&n,&m)){
            if(n==0 && m==0)
                break;
            num[0]=0;
            for(int i=1;i<=n;i++){
                scanf("%d",&num[i]);
                if(num[i]>m)
                    i--,n--;
            }
            int cnt=n+1;
            for(int i=1;i<=n;i++)
                for(int j=i;j<=n;j++)
                    if(num[i]+num[j]<=m)
                        num[cnt++]=num[i]+num[j];
            sort(num,num+cnt);
            int max=0,l,r=cnt-1,cur=cnt-1;
            for(int i=0;i<cnt;i++){
                l=i;
                while(l<=r){
                    int mid=(l+r)>>1;
                    int tmp=num[i]+num[mid];
                    if(tmp>m)
                        r=mid-1;
                    else if(tmp<m){
                        l=mid+1;
                        if(max<tmp){
                            cur=mid;
                            max=tmp;
                        }
                    }else{
                        max=m;
                        i=cnt;
                        break;
                    }
                }
                r=cur;
            }
            printf("Case %d: %d\n",++cases,max);
            printf("\n");
        }
        return 0;
    }
     
  • 相关阅读:
    2804 最大最小数质因数
    5429 多重背包
    1851 越狱
    Gvim使用
    3622 假期
    4906 删数问题
    2845 排序的代价
    poj 3352
    常用正则表达式汇总
    功能简单例子
  • 原文地址:https://www.cnblogs.com/jackge/p/3085659.html
Copyright © 2011-2022 走看看