zoukankan      html  css  js  c++  java
  • Hangover 分类: POJ 2015-06-11 10:34 12人阅读 评论(0) 收藏

    Hangover
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 108765   Accepted: 53009

    Description

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00
    

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)
    水题,不说了,还是看代码
    
    #include <iostream>
    #define exp 1e-6
    using namespace std;
    double sum[300];
    int main()
    {
        sum[0]=0;
        for(int i=1;i<=300;  i++)
        {
            sum[i]=(1.0/(i+1))+sum[i-1];
        }
        double len;
        while(cin>>len)
        {
            if(len<exp)
            {
                break;
            }
            for(int i=1;i<=300;i++)
            {
                if(len<sum[i])
                {
                    cout<<i<<" card(s)"<<endl;
                      break;
                }
    
            }
    
        }
        return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    SpringBoot整合Ehcache
    SpringCache整合Redis
    SpringBoot使用mongo搭建RESTful风格
    SpringBoot使用JPA搭建RESTful风格
    SpringBoot操作mongo的两种方法
    Nginx负载均衡
    【Java杂货铺】用Security做权限极简入门
    【Java杂货铺】JVM#虚拟机加载机制
    【Java杂货铺】JVM#Class类结构
    【Java杂货铺】JVM#Java高墙之GC与内存分配策略
  • 原文地址:https://www.cnblogs.com/juechen/p/4722043.html
Copyright © 2011-2022 走看看