zoukankan      html  css  js  c++  java
  • 华为无线WLAN二层 三层组网实例

    配置流程总结
    常用配置流程
    2层组网
    规划管理vlan 、业务vlan 、APwlan
    1. 配置好交换机基本信息
    2. 配置DHCP FOR_AP DHCP FOR_STA
    3. AC配置vlan,管理地址,接口信息,
    4. AP上线需要在AC上配置   国家码CN(默认模版)  AP认证方式(默认为MAC认证),配置AC的源接口(AC管理地址或管理VLAN)   ----------------- 此时正常情况下,已经可以看到AP上线
    5. 新增ssid业务
     5.1 SSID 模版  ssid-profile name XXX
     5.2 安全模版 security-profile name XXX    (认证方式)
     5.3 VAP模版 vap-profile name XXX
      5.3.1 转发方式 (集中转发 本地转发)
      5.3.2 绑定SSID模版
      5.3.3 绑定安全模版
      5.3.4 配置业务vlan   
        A: service-vlan vlan-id vlan-id(1-4094)此处表示业务VLAN 10 
        B: service-vlan vlan-pool  vlan组名    此处表示可绑定多个业务vlan,要提前定义vlan-pool 
    6. 配置AP-Group1
     6.1 新建AP组,并绑定VAP模版至wlan1 radio 0/1     0表示2.4G 1表示5G
     6.2 调整AP所属组    *****通过AP ID方式
       6.2.1 AP ID 可通过dia ap all 查看
       6.2.2 ap-regroup ap-id 1 new-group AP-Group1   表示将ID为1 的ap加入到AP-Group1组
     6.3 调整AP所属组    *****通过AP name方式
       6.3.1 通过AP ID方式重命名AP name
         ap-rename ap-id 1 new-name 13F_AP1   表示将ID为1 的AP重命名为13F_AP1
       6.3.2 ap-regroup ap-name 13F_AP1 new-group AP-Group1 表示将名字为13F_AP1的AP-Group1组 
     
     
     
    二层组网方式
    需求:
    1. 用户使用密码认证上线 ,共计2个SSID
    2. 管理vlan100 网关192.168.100.254
    3. 业务vlan101 网关192.168.101.254
    4. 本地转发

    交换机配置:
     ==================
    vlan batch 100 101
    int vlan 100
    ip add 192.168.100.254 24
    dhcp select global
    undo shutdown
    int vlan 101
    ip add 192.168.101.254 24
    dhcp select global
    undo shutdown
     ===================
    DHCP配置
    dhcp enable
    ip pool vlan100
    network 192.168.100.0 mask 24
    gateway 192.168.100.254
    ip pool vlan101
    network 192.168.101.254 mask 24
    gateway-list 192.168.101.254
     ====================
    端口配置
    int g0/0/1
    port lint-type trunk
    port trunk allow-pass vlan all
    int g0/0/2 
    port link-type trunk
    port trunk pvid vlan 100
    port trunk allow-pass vlan all
    int g0/0/3
    port link-type trunk
    port trunk pvid vlan 100
    port trunk allow-pass vlan all
    int g0/0/4
    port link-type trunk
    port trunk pvid vlan 100
    port trunk allow-pass vlan all

    =========此时,设备网络互连配置完成,接下来配置AC基本配置
    [AC]
    配置域管理模板
    wlan
     regulatory-domain-profile name default     //主要配置国家码,可以使用默认模板,通用
      country-code CN 
      quit
     ap auth-mode no-auth         //表示AP的认证方式为不需要认证

     ap-group name default
      regulatory-domain-profile default          //在AP组下引用域管理模板。default为域管理模板名称
         ------------------
     capwap source interface vlanif 100
     或者
     capwap source ip-address 192.168.100.254  
         --------------------------配置AC的源接口 以上2种方式任选一种

       =========此时AP可自动上线    可通过dis ap all查看
    配置SSID模板
    wlan
     ssid-profile name ssid_comlan              //ssid-comlan 表示ssid模板名称
      ssid comlan            //comlan 表示SSID名称
    配置安全认证模板
    wlan
     security-profile name sec_psk     //sec_psk为认证模板名称,方式为PSK密码认证;名称可用认证类型来定义,比如raduis 
      security wpa-wpa2 psk pass-phrase comlan888 aes   //表示加密类型wpa-wap2 认证密码为comlan888
    配置vap模板
    wlan
     vap-profile name vap_comlan    //vap-comlan表示模板名称,
     service-vlan vlan-id 101      //PC端获取的vlan
     ssid-profile ssid-cmcc       //调用配置的SSID模板
     security-profile sec_psk      //调用配置的安全模板
    配置AP组
    wlan
     ap-group name default
      vap-profile vap_comlan wlan 1 radio 0 
      vap-profile vap_comlan wlan 1 radio 1
      OR
      vap-profile vap_comlan wlan 1 radio all     //0表示2.4G 1表示5G wlan 1表示第一个无线(可理解为wlan1 是第一个SSID wlan 2 是第二个SSID)


    此为最基本配置,pc端可正常连接AP,且可以获取业务网段IP地址,AC 和AP此时为2层网络互通,如配置3层互通需配置option
    ====================================================================================
     
     
    三层组网方式
    配置需求
     1. AP AC不在同一网段
     2. 核心作为DCHP 服务器为AP 和Client分配地址
     3. AP地址网段 VLAN10 172.16.20.0 24
     4. Client地址网段 VLAN20 192.168.20.0 24
     5. 所有网关都在核心

    与二层组网区别
     1. AP和AC不在同一vlan
     2. 需要配置option 43 字段来告诉AP,AC的地址是哪个

    配置详情
     1. 核心
      vlan batch vlan 10 20 30 
      int vlan 10 
       des AP-MGT
       ip add 172.16.20.0 24
       dhcp select global
      int vlan 20 
       des Client-DCHP 
       ip add 192.168.20.0 24
       dchp select global
      int vlan 30
       des to-AC
       ip add 172.16.10.254 24
      ip pool vlan10
       network 172.16.20.0 mask 24
       gat 172.16.20.254
       option 43 sub-option 3 ascii 172.16.10.253
      ip pool vlan20
       network 192.168.20.0 24
       gat 192.168.20.254
      int g0/0/1
       port link-type trunk
       port trunk allow-pass vlan all
      int g0/0/2
       port link-type trunk
       port trunk allow-pass vlan all
       port trunk pvid vlan 10
      int g0/0/3
       port link-type trunk
       port trunk allow-pass vlan all
       port trunk pvid vlan 10
      int g0/0/4
       port link-type trunk 
       port trunk allow-pass vlan all
       port trunk pvid vlan 10
      2. AC配置
       vlan 30 
       int vlan 30
        ip add 172.16.10.253 24
        quit
       wlan 
        reg name defalt 
         coun CN
        ap-group name default
         reg default
        ap auth-mode no-auth
        quit
       capwap sou inter vlanif 30 

       ***
       sec name auth-psk
        sec wpa-wpa2 psk pass-phrase comlan888 aes
       ssid name ssid-cmcc
        ssid cmcc
       vap-profile name vap-cmcc
        for dir
        sec auth-psk
        ssid ssid-cmcc
        service-vlan vlan-id 20 
       ap-group name default
        vap-profile vap-cmcc wlan 1 radio 0 
        vap-profile vap-cmcc wlan 1 radio 1
       
    ==========================
     本博客内容已同步至个人博客系统:runbash.com
  • 相关阅读:
    ionic4 无限滚动加载组件 ion-infinite-scroll-content 的loadingSpinner 属性
    ionic cordova build android 报错 解决
    ionic4 标题栏 ion-toolbar 默认 底部会显示一个底边框 解决
    ionic3 在ios12.2 12.3 12.4上页面无法滚动
    Android 打生产包(release)生成密钥(证书)及签名
    在Vue.js应用程序中使用Ionic 4组件
    ionic4 ionic-native列表
    清除 多行li 行间距
    Connection Pool
    Logging
  • 原文地址:https://www.cnblogs.com/kailsay/p/12470567.html
Copyright © 2011-2022 走看看