zoukankan      html  css  js  c++  java
  • HDU 1049 Climbing Worm(水题)

    Climbing Worm

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7047    Accepted Submission(s): 4455


    Problem Description
    An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
     
    Input
    There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
     
    Output
    Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
     
    Sample Input
    10 2 1 20 3 1 0 0 0
     
    Sample Output
    17 19
     
    Source
     
     
     
    水题。
    总长为n,上升一秒走u,休息一秒下降d.
    相当于每两秒走(u-d);
    先n-u,得到过了多少个u-d后超过n-u;
    int t=(n-u)/(u-d);
            if(t*(u-d)<(n-u)) t++;
            t*=2;
            t++;
    就是最后一秒可以一步到达~~~
    代码:
    #include<stdio.h>
    int main()
    {
    int n,u,d;
    while(scanf("%d%d%d",&n,&u,&d),n)
    {
    int t=(n-u)/(u-d);
    if(t*(u-d)<(n-u)) t++;
    t*=2;
    t++;
    printf("%d\n",t);
    }
    return 0;
    }
  • 相关阅读:
    C#与JS实现 获取指定字节长度 中英文混合字符串 的方法
    CKFinder_AspDotNet_2.4 破解方法 去版权
    MVC3中如何输出富文本
    CKEditor与CKFinder整合 MVC3
    vue项目多页配置
    设备宽度
    h5前端项目常见问题汇总
    react分享
    javascript-复制
    vue开发笔记
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2413324.html
Copyright © 2011-2022 走看看