zoukankan      html  css  js  c++  java
  • POJ 2240 Arbitrage(求正环)

     

    Arbitrage

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11008   Accepted: 4629

    Description

    Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

    Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

    Input

    The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
    Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

    Sample Input

    3
    USDollar
    BritishPound
    FrenchFranc
    3
    USDollar 0.5 BritishPound
    BritishPound 10.0 FrenchFranc
    FrenchFranc 0.21 USDollar
    
    3
    USDollar
    BritishPound
    FrenchFranc
    6
    USDollar 0.5 BritishPound
    USDollar 4.9 FrenchFranc
    BritishPound 10.0 FrenchFranc
    BritishPound 1.99 USDollar
    FrenchFranc 0.09 BritishPound
    FrenchFranc 0.19 USDollar
    
    0
    

    Sample Output

    Case 1: Yes
    Case 2: No
    

    Source

     
     
     
    求正环。
    分别用了bellman和floyed算法,好像时间都差不多。
     
     
    /*
    POJ 2240
    G++ 784K 797ms
    
    */
    
    
    #include<stdio.h>
    #include<algorithm>
    #include<map>
    #include<iostream>
    #include<string>
    #include<string.h>
    using namespace std;
    
    const int MAXN=110;
    const int MAXE=1100;
    double dist[MAXN];
    int edge[MAXE][2];
    double d[MAXE];
    int tol;
    
    bool bellman(int start,int n)
    {
        for(int i=1;i<=n;i++)dist[i]=0;
        dist[start]=1;
        for(int i=1;i<n;i++)
        {
            bool flag=false;
            for(int j=0;j<tol;j++)
            {
                int u=edge[j][0];
                int v=edge[j][1];
                if(dist[v]<dist[u]*d[j])
                {
                    flag=true;
                    dist[v]=dist[u]*d[j];
                }
            }
            if(!flag)return false;//没有正环
        }
    
        for(int j=0;j<tol;j++)
          if(dist[edge[j][1]]<dist[edge[j][0]]*d[j])
            return true;
        return false;
    }
    map<string,int>mp;
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int n;
        string str1,str2;
        int iCase=0;
        int m;
        while(scanf("%d",&n),n)
        {
            iCase++;
            mp.clear();
    
            for(int i=1;i<=n;i++)
            {
                cin>>str1;
                mp[str1]=i;
            }
            scanf("%d",&m);
            double tmp;
            tol=0;
            while(m--)
            {
                cin>>str1>>tmp>>str2;
                edge[tol][0]=mp[str1];
                edge[tol][1]=mp[str2];
                d[tol++]=tmp;
            }
            printf("Case %d: ",iCase);
            bool flag=false;
            for(int i=1;i<=n;i++)
            {
                if(bellman(i,n))
                {
                    flag=true;
                    break;
                }
            }
            if(flag)printf("Yes\n");
            else printf("No\n");
        }
        return 0;
    }

    程序2:floyed

    /*
    POJ 2240
    G++ 784K 797ms
    
    */
    
    
    #include<stdio.h>
    #include<algorithm>
    #include<map>
    #include<iostream>
    #include<string>
    #include<string.h>
    using namespace std;
    
    const int MAXN=110;
    double dist[MAXN][MAXN];
    
    
    void floyed(double dis[][MAXN],int n)//结点编号1-n
    {
        int i,j,k;
        for(k=1;k<=n;k++)
           for(i=1;i<=n;i++)
             for(j=1;j<=n;j++)
               if(dis[i][j]<dis[i][k]*dis[k][j])
                  dis[i][j]=dis[i][k]*dis[k][j];
    }
    map<string,int>mp;
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int n;
        string str1,str2;
        int iCase=0;
        int m;
        while(scanf("%d",&n),n)
        {
            iCase++;
            mp.clear();
            for(int i=1;i<=n;i++)
            {
                cin>>str1;
                mp[str1]=i;
            }
            for(int i=1;i<=n;i++)
              for(int j=1;j<=n;j++)
              {
                  if(i==j)dist[i][j]=1;
                  else dist[i][j]=0;
              }
            scanf("%d",&m);
            double tmp;
            while(m--)
            {
                cin>>str1>>tmp>>str2;
                int a=mp[str1];
                int b=mp[str2];
                dist[a][b]=tmp;
            }
            printf("Case %d: ",iCase);
            bool flag=false;
            floyed(dist,n);
            for(int i=1;i<=n;i++)
            {
                if(dist[i][i]>1)
                {
                    flag=true;
                    break;
                }
            }
            if(flag)printf("Yes\n");
            else printf("No\n");
        }
        return 0;
    }
  • 相关阅读:
    ruby_debug笔记
    来自Neil
    rails 在迭代里的那些条件
    rails 表单嵌套
    rails present? 和 blank? 对于bool 值
    泛泛
    设计模式——策略模式
    Spring容器初始化过程
    Spring之ResourceLoader加载资源
    Spring之ClassPathResource加载资源文件
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2645744.html
Copyright © 2011-2022 走看看