zoukankan      html  css  js  c++  java
  • 2014 ACM/ICPC Asia Regional Xi'an Online poj5007 Post Robot

    Problem Description
    DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog.

    But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically.

    After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will make a comment “MAI MAI MAI!”, and go on reading the post.

    In order to make it more funny, you, as a fan of Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.
     

    Input
    A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘ ’ in C/C++), LF(ASCII code 10, ‘ ’ in C/C++), please process input until EOF. Note all characters are case sensitive.

    The size of the article does not exceed 8KB.
     

    Output
    Output should contains comments generated by your script, one per line.
     

    Sample Input
    Apple bananaiPad lemon ApplepiSony 233 Tim cook is doubi from Apple iPhoneipad iPhone30 is so biiiiiiig Microsoft makes good App.
     

    Sample Output
    MAI MAI MAI! MAI MAI MAI! MAI MAI MAI! SONY DAFA IS GOOD! MAI MAI MAI! MAI MAI MAI! MAI MAI MAI!
     




    #include <iostream>
    #include<string>
    #include  <stdio.h>
    using namespace std;
    int main()
    {
    string a ;
    while(getline(cin,a))
    {int n=a.length();
    int i;
    for(i=0;i<n;i++)
    {


        if(a[i]=='A')
    {if(a.substr(i, 5)=="Apple")
        cout<<"MAI MAI MAI!"<<endl;}

    else if(a[i]=='S')
    {if(a.substr(i, 4)=="Sony")
        cout<<"SONY DAFA IS GOOD!"<<endl;}
    else if(a[i]=='i')
    {bool p1=0;
        {if(a.substr(i, 6)=="iPhone")p1=1;
            if(a.substr(i, 4)=="iPod")p1=1;
            if(a.substr(i, 4)=="iPad")p1=1;}
            if(p1==1)cout<<"MAI MAI MAI!"<<endl;


        }

    }

    }
    return 0;
    }


  • 相关阅读:
    java实现第七届蓝桥杯平方圈怪
    Java三大器之过滤器(Filter)的工作原理和代码演示
    spring mvc 防止重复提交表单的两种方法,推荐第二种
    防止订单重复提交
    Swagger入门教程
    BigDecimal的用法详解(保留两位小数,四舍五入,数字格式化,科学计数法转数字,数字里的逗号处理)
    很认真的聊一聊程序员的自我修养
    JAVA利用反射映射JSON对象为JavaBean
    Eclipse导出JavaDoc(并解决中文乱码问题)
    Eclipse注释模板设置详解
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387793.html
Copyright © 2011-2022 走看看