zoukankan      html  css  js  c++  java
  • POJ 1163 The Triangle(简单动态规划)

    http://poj.org/problem?id=1163

    The Triangle
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 32923   Accepted: 19514

    Description

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    Output

    Your program is to write to standard output. The highest sum is written as an integer.

    Sample Input

    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Source

    [Submit]   [Go Back]   [Status]   [Discuss]

    Home Page   Go Back  To top

    简单的动态规划。。。

     By LFENG
     
    #include<stdio.h>
    int main()
    {
        
    int a[102][102];
        
    int n,i,j;
        scanf(
    "%d",&n);
        
    for(i=0;i<n;i++)
        
    for(j=0;j<=i;j++)
        scanf(
    "%d",&a[i][j]);
        
    for(i=n-2;i>=0;i--)
        
    for(j=0;j<=i;j++)
        a[i][j]+=(a[i+
    1][j]>a[i+1][j+1])?a[i+1][j]:a[i+1][j+1];
        printf(
    "%d ",a[0][0]);
        
    return 0;
    }
  • 相关阅读:
    003 python接口 cookies
    RocketDock 安装
    001 python接口 get请求
    mysql创建远程登陆用户并授权
    php时间函数
    ThinkPHP5高阶实战教程
    unset与unlink
    include 和require的区别
    80端口被system 占用
    【纪中受难记】——C2Day4:水题大赏
  • 原文地址:https://www.cnblogs.com/lfeng/p/3149002.html
Copyright © 2011-2022 走看看