zoukankan      html  css  js  c++  java
  • Cow Bowling

    Cow Bowling
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 13481   Accepted: 8909

    Description

    The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

              7
    
    
    
            3   8
    
    
    
          8   1   0
    
    
    
        2   7   4   4
    
    
    
      4   5   2   6   5
    Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

    Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

    Input

    Line 1: A single integer, N 

    Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

    Output

    Line 1: The largest sum achievable using the traversal rules

    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Hint

    Explanation of the sample: 

              7
    
             *
    
            3   8
    
           *
    
          8   1   0
    
           *
    
        2   7   4   4
    
           *
    
      4   5   2   6   5
    The highest score is achievable by traversing the cows as shown above.
    数塔问题!!!又名数字三角形
     
    递推方法
    #include<stdio.h>
    #include<string.h>
    #include<stdlib.h>
    #include<algorithm>
    #define N 351
    using namespace std;
    int main()
    {
        int n,i,j,dp[N][N],map[N][N];
        scanf("%d",&n);
        for(i=1;i<=n;i++)
           for(j=1;j<=i;j++)
           {
                scanf("%d",&map[i][j]);
           }
        for(i=1;i<=n;i++)
            dp[n][i]=map[n][i];//最后一行,用新数组存好。运算时新数组其他为原始的0,计算更加好 
        for(i=n-1;i>=1;i--)
            for(j=1;j<=i;j++)
                dp[i][j]=map[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
    //用到max()的时候,要么自己写一个max比较函数,要么用函数名 algorithm和using namespace std一起 
        printf("%d",dp[1][1]);
        return 0;
    }
  • 相关阅读:
    进程同步
    CPU调度
    线程的引入
    进程互斥
    处理器状态
    操作系统
    进程的基本概念
    socket应用
    html笔记
    HTTP基本链接原理
  • 原文地址:https://www.cnblogs.com/lipching/p/3910054.html
Copyright © 2011-2022 走看看