zoukankan      html  css  js  c++  java
  • hdu1036

    Average is not Fast Enough!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3336    Accepted Submission(s): 1306


    Problem Description
    A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race. 

    You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it? 
    So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
     
    Input
    The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
     
    Output
    For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
     
    Sample Input
    2 12.5
    5 0:23:21 0:25:01
    42 0:23:32 -:--:--
    7 0:33:20 0:41:35
     
    Sample Output
    5: 3:52 min/km
    42: - 7:6:00 min/km
     
     
    Source
     

    #include <iostream>
    #include<stdio.h>
    using namespace std;

    int main()
    {
        int f, n, i, a, sum, h, m, s;
        double d;
        char c[20], t[100];
        scanf("%d%lf", &n, &d);
        while (~scanf("%d", &a))
        {
            sum = f = 0;
            for (i=1;i<=n;++i)
            {
                scanf("%s", c);
                if (c[0] == '-') f = 1;
                sscanf(c, "%d:%d:%d", &h, &m, &s);
                sum += h*3600 + m*60 + s;
            }
            if (f)
            printf("%3d: - ", a);
            else
            {
                sum = int(sum/d + 0.5);
                printf("%3d: %d:%2.2d min/km ", a, sum/60, sum%60);
            }
        }
        return 0;
    }

  • 相关阅读:
    实现路由的RouterMiddleware中间件
    AI: Jarvis
    使用管道(PipeLine)和批量(Batch)操作
    OSWatcher Black Box
    NET Core HTTP 管道
    开源项目!
    Router的创建者——RouteBuilder
    .NET Core)的ZooKeeper异步客户端
    single-write-database-connection
    Quartz与Spring集成 Job如何自动注入Spring容器托管的对象
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3330655.html
Copyright © 2011-2022 走看看