zoukankan      html  css  js  c++  java
  • hdu3037Saving Beans

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2610    Accepted Submission(s): 966


    Problem Description
    Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

    Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
     

    Input
    The first line contains one integer T, means the number of cases.

    Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
     

    Output
    You should output the answer modulo p.
     

    Sample Input
    2 1 2 5 2 1 5
     

    Sample Output
    3 3
    Hint
    Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.
     

    Source
     

    #include<map>
    #include<string>
    #include<cstring>
    #include<cstdio>
    #include<cstdlib>
    #include<cmath>
    #include<queue>
    #include<vector>
    #include<iostream>
    #include<algorithm>
    #include<bitset>
    #include<climits>
    #include<list>
    #include<iomanip>
    #include<stack>
    #include<set>
    using namespace std;
    typedef long long ll;
    ll qpow(ll a,ll b,ll c)
    {
    	ll ans=1;
    	while(b>0)
    	{
    		if(b&1)
    			ans=ans*a%c;
    		a=a*a%c;
    		b>>=1;
    	}
    	return ans;
    }
    ll fac[100000];
    ll fmt(ll a,ll b,ll c)
    {
    	return fac[a]*qpow(fac[b]*fac[a-b]%c,c-2,c)%c;
    }
    ll lucas(ll a,ll b,ll c)
    {
    	ll ans=1;
    	while(a>0&&b>0)
    	{
    		if(a%c<b%c)
    			return 0;
    		ans=ans*fmt(a%c,b%c,c)%c;
    		a/=c;
    		b/=c;
    	}
    	return ans;
    }
    void create(ll a)
    {
    	fac[0]=1;
    	for(ll i=1;i<a;i++)
    		fac[i]=fac[i-1]*i%a;
    }
    int main()
    {
    	int T;
    	cin>>T;
    	while(T--)
    	{
    		ll n,m,p;
    		cin>>n>>m>>p;
    		create(p);
    		cout<<lucas(n+m,m,p)<<endl;
    	}
    }


  • 相关阅读:
    敏捷实践:比每日会议更疯狂的半日会议!
    视频分享:编码与代码评审质量与现实的最激烈冲突点
    项目管理的“三边六拍”!
    挨踢项目求生法则需求篇
    恭喜一棵树博客开通
    盛大格子客或将继开心农场之后又一疯狂游戏
    离线安装.NETFRAMEWORK 3.5
    世界上尽有如此恶俗的软件还广为流传
    为什么是一棵树?
    java 之 注解
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5083439.html
Copyright © 2011-2022 走看看