zoukankan      html  css  js  c++  java
  • [ACM] POJ 2524 Ubiquitous Religions (并查集)

    Ubiquitous Religions
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 23093   Accepted: 11379

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    Hint

    Huge input, scanf is recommended.

    Source


    解题思路:

    并查集的简单应用。

    最后分成了多少集合就是结果。

    代码:

    #include <iostream>
    #include <stdio.h>
    using namespace std;
    const int maxn=50010;
    int parent[maxn];
    int n,m;
    
    void init(int n)
    {
        for(int i=1;i<=n;i++)
            parent[i]=i;
    }
    
    int find(int x)
    {
        return parent[x]==x?x:find(parent[x]);
    }
    
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)
            return ;
        else
            parent[x]=y;
    }
    
    
    int main()
    {
        int c=1;
        while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
        {
            int x,y;
            init(n);
            for(int i=1;i<=m;i++)
            {
                scanf("%d%d",&x,&y);
                unite(x,y);
            }
            int cnt=0;
            for(int i=1;i<=n;i++)
                if(parent[i]==i)
                    cnt++;
            cout<<"Case "<<c++<<": "<<cnt<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    Selenium Webdriver 自动化测试开发常见问题(C#版)VS
    HTML 和 Body 在 CSS 中的区别
    安装SDK时出现Fetching https://dl-ssl.google.com/android/repository/addons_list-1.xml
    配置好Java和SDK的环境变量后,Javac不是内部命令
    关于adb连接手机offline的问题解决
    CSDN上总结的测试工具排名
    关于性能优化
    关于WAS_1
    IIS服务器搭建
    关于WAS
  • 原文地址:https://www.cnblogs.com/mfmdaoyou/p/6714477.html
Copyright © 2011-2022 走看看