zoukankan      html  css  js  c++  java
  • hdu6092 01背包

    Rikka with Subset

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 658    Accepted Submission(s): 297


    Problem Description
    As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

    Yuta has n positive A1An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .

    Now, Yuta has got 2n numbers between [0,m] . For each i[0,m] , he counts the number of i s he got as Bi .

    Yuta shows Rikka the array Bi and he wants Rikka to restore A1An .

    It is too difficult for Rikka. Can you help her?  
     
    Input
    The first line contains a number t(1t70) , the number of the testcases.

    For each testcase, the first line contains two numbers n,m(1n50,1m104) .

    The second line contains m+1 numbers B0Bm(0Bi2n) .
     
    Output
    For each testcase, print a single line with n numbers A1An .

    It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
     
    Sample Input
    2
    2 3
    1 1 1 1
    3 3
    1 3 3 1
     
    Sample Output
    1 2
    1 1 1
     
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int N=1e4+88;
    typedef long long LL;
    LL dp[N],B[N];
    int a[N];
    int main(){
        int n,m,T;
        for(scanf("%d",&T);T--;){
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;++i) scanf("%I64d",&B[i]);
        dp[0]=1;
        for(int i=1;i<=m;++i){
            if(dp[i]==B[i]) continue;
            a[i]=B[i]-dp[i];
            for(int j=1;j<=a[i];++j) for(int k=m;k>=i;--k) dp[k]+=dp[k-i];
        }
        int i;
        for(i=1;i<=m;++i) if(a[i]--) {printf("%d",i);break;}
        for(;i<=m;++i) while(a[i]--) printf(" %d",i);
        puts("");
        }
    }
  • 相关阅读:
    linux系统命令学习系列-用户切换命令su,sudo
    linux系统命令学习系列-用户组管理
    linux系统命令学习-用户管理
    python web开发-flask中sqlalchemy的使用
    python web开发-flask连接sqlite数据库
    python实现bt种子 torrent转magnet
    prefProvider.kt
    douyin-bot-代码
    pyadb关于python操作adb的资料
    bottle源码
  • 原文地址:https://www.cnblogs.com/mfys/p/7308968.html
Copyright © 2011-2022 走看看