zoukankan      html  css  js  c++  java
  • zoj 1760 Doubles

    Doubles

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

    1 4 3 2 9 7 18 22

    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.


    Input

    The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.


    Output

    The output will consist of one line per input list, containing a count of the items that are double some other item.


    Sample Input

    1 4 3 2 9 7 18 22 0
    2 4 8 10 0
    7 5 11 13 1 3 0
    -1


    Sample Output

    3
    2
    0

    分析:用set,检索速度快

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <set>
    using namespace std;
    int main(){
        set<int> s;
        int n, sum;
        while(cin >> n){
            if(n == -1)
                break;
            sum = 0;
            s.clear();
            s.insert(n);
            while(cin >> n){
                if(n == 0)
                    break;
                s.insert(n);
            }
            set<int>::iterator it = s.begin();
            while(it != s.end()){
                if(s.find(2 * (*it)) != s.end())
                    sum++;
                it++;
            }
            cout << sum << endl;
        }
        return 0;
    }
  • 相关阅读:
    Photoshop教程,视频MP4格式转换为GIF格式
    pyqgis环境配置
    R 输出函数 格式化输出 打印函数
    linux ubuntu 更改终端的默认设置,终端大小,字体
    wps 显示所有的字符,将参考文献排序,插入目录
    在 word 中 怎么让表格旋转方向
    linux argc argv
    linux 命令行的快捷键 vim
    linux 操作系统,以及一般的操作系统 所看书籍
    win 10 快速启动 某些程序
  • 原文地址:https://www.cnblogs.com/qinduanyinghua/p/6536039.html
Copyright © 2011-2022 走看看