zoukankan      html  css  js  c++  java
  • hdu 1061 暴力

    Rightmost Digit

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 29108    Accepted Submission(s): 11115


    Problem Description
    Given a positive integer N, you should output the most right digit of N^N.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single positive integer N(1<=N<=1,000,000,000).
     
    Output
    For each test case, you should output the rightmost digit of N^N.
     
    Sample Input
    2 3 4
     
    Sample Output
    7 6
    Hint
    In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
     
    Author
    Ignatius.L
     
    低位相乘与高位无关
    import java.util.Scanner;
    
    
    public class Main {
    
    	/**
    	 * @param args
    	 */
    	public static void main(String[] args) {
    		// TODO Auto-generated method stub
    		Scanner s = new Scanner(System.in);
    		int t = s.nextInt();
    		for(int i=0; i<t; i++){
    			int n=s.nextInt();
    			int[][] a ={
    					{0},{1},{6,2,4,8},
    					{1,3,9,7},
    					{6,4},
    					{5},
    					{6},
    					{1,7,9,3},
    					{6,8,4,2},
    					{1,9}
    			};
    			int[] l = {1,1,4,4,2,1,1,4,4,2};
    			int d = n%10;
    			System.out.println(a[d][n%l[d]]);
    		}
    	}
    
    }
    
  • 相关阅读:
    移动端Web前端注解
    Atom 必备插件
    Gulp 前端自动化构建
    RESTful API 设计
    Cookie 的 增删查
    三步实现 AngularJS URL 去 # 号
    AngularJS $http 之 POST 传参
    Angular.JS中使用$watch监听模型变化
    AngularJS $apply() 解析
    [个人笔记]IDEA+MAVEN+testNG(reportNG)
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3587349.html
Copyright © 2011-2022 走看看