zoukankan      html  css  js  c++  java
  • Cheapest Palindrome POJ

    Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

    Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

    FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

    Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

    Input
    Line 1: Two space-separated integers: N and M
    Line 2: This line contains exactly M characters which constitute the initial ID string
    Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
    Output
    Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
    Sample Input
    3 4
    abcb
    a 1000 1100
    b 350 700
    c 200 800
    Sample Output
    900
    Hint
    If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
     
    题解:
      这个题目有wa了一次,才a。
      套路区间dp的解法,dp[i][j]表示把i~j改成回文的最小代价。如果s[i]==s[j]那么显然有一种转移dp[i][j]=dp[i+1][j-1],然后就是第二种可以一个一个删除或者加,dp[i][j]=dp[i+1][j]+cost[s[i]-'a'],dp[i][j]=dp[i][j-1]+cost[s[j]-'a']。
     
    代码:
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    #include <iostream>
    #define MAXN 2010
    using namespace std;
    char s[MAXN];
    int dp[MAXN][MAXN];
    int cost[MAXN];
    int n,len;
    
    int main()
    {
        scanf("%d%d",&n,&len);
        scanf("%s",s+1);
        for(int i=1;i<=n;i++){
            char x;scanf("%c",&x);scanf("%c",&x);
            int xx,yy;
            scanf("%d%d",&xx,&yy);cost[x-'a']=min(xx,yy);
        }
        memset(dp,127/3,sizeof(dp));
        for(int i=1;i<=len;i++) dp[i][i]=0,dp[i][i-1]=0;
        for(int lenn=1;lenn<len;lenn++){
            for(int i=1;i+lenn<=len;i++){
                int j=i+lenn;
                if(s[i]==s[j]) dp[i][j]=dp[i+1][j-1];
                dp[i][j]=min(dp[i][j],min(dp[i+1][j]+cost[s[i]-'a'],dp[i][j-1]+cost[s[j]-'a']));
            }
        }
        printf("%d",dp[1][len]);
        return 0;
    }
  • 相关阅读:
    【工具】sublime使用技巧
    怎样存钱利息最大及怎样买房付款最省钱问题
    存钱问题
    玛丽莲问题
    用线程做一个火车票购票系统(可以根据需要选择线程个数)
    系统编程拷贝文件或者目录(可以做出一个动态库哦)
    mysql优化-数据库设计基本原则
    项目 数据可视化1
    读书笔记2-三体
    python数据学习3 布林带
  • 原文地址:https://www.cnblogs.com/renjianshige/p/7510598.html
Copyright © 2011-2022 走看看