zoukankan      html  css  js  c++  java
  • poj3253Fence Repair (Huffman)

    Huffman树:具有n个外部节点(叶子节点)的二叉树

                         每个外部节点都有一个对应的权值Wi

                叶节点带权外部路径长度总和WPL=Wi*Li(i从1到n)最小(权越大的节点里根越进)

    构造Huffman树:1)根据给定的n个权值{W1,W2,W3......Wn}构成n棵二叉树的集合F={T1,T2,T3......Tn},其每棵二叉树只有一个权值为Wi的根节点

                                 2)在F中取两棵根节点权值最小的树作为左右子树构造一棵新的二叉树,且令新二叉树的根节点的权值为左右子树根节点权值的和,

                                 3)在F中删除这两棵树,同时将新得到的二叉树加入到几何中(其实只是让新二叉树的根节点的权值加入到集合中)

             4)重复2)和3),直到F中只含一棵树为止。

     2  4  5  7 四个数的Huffman树的构建: 

    也就是:

    嗯嗯,也就是在专业课离散数学中学到的最优二叉树的构建过程

    而Huffman树的一个典型应用是:计算最短前缀编码(一个字母的编码不是(任何)另一个编码的前缀的部分)。

    用最优二叉树理解就是任何一个子节点都不是另一个子节点的祖先路径的一部分。

    介绍完Huffman树,接下来就看看这道poj的题

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
     
     

    这道题一共要得到n块木板,对于每块木板,要想得到这样长的木板,肯定是有更大一块的木板一刀切成两块得到的,这跟特殊的二叉树一样,每个节点下面只能有且仅有两个节点。而要求结果就是所有的空白部分,即二叉树中的非外部节点的值的和。而每个空白节点都是由其左右子节点的值的和构成,分解之后,会发现最后的和就是叶子节点的权值乘以叶子节点的高度(叶子节点到根节点的长度),而这就是典型的0Huffman树。

    然后这道题利用vector动态数组做的话不会超时。

    现附上AC代码:

    #include<iostream>
    #include<vector>
    using namespace std;
    vector <long long int > q;
    long long int Min();
    int main()
    {
    int n;
    long long int sum=0;
    cin>>n;
    for(int i=0;i<n;i++)
    {
    long long int a;
    scanf("%lld",&a);
    q.push_back(a);
    }
    while(1)
    {
    long long int s1=Min(),s2;
    if(q.size()!=0)
    s2=Min();
    else
    {
    cout<<sum<<endl;
    return 0;
    }
    sum+=s1+s2;
    q.push_back(s1+s2);
    }
    }

    long long int Min()
    {
    long long int min1=q[0];
    int x=0;
    for(int i=0;i<q.size();i++)
    {
    if(q[i]<min1) min1=q[i],x=i;
    }
    q.erase(q.begin()+x);
    return min1;
    }

    注意这道题的根本结果就是所有空白节点的和。 


    作者:孙建钊
    出处:http://www.cnblogs.com/sunjianzhao/
    本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。

  • 相关阅读:
    【转】nginx(一) nginx详解
    美好生活需要全方位的保障
    Oracle私网mtu滚动修改实施方案
    小知识:后台执行Oracle创建索引免受会话中断影响
    小知识:Oracle RAC添加服务名实现单节点访问
    Windows平台安装Oracle11.2.0.4客户端报错INS-30131
    小知识:如何赋予用户查看所有存储过程和触发器的权限
    小知识:如何判定crontab任务的执行频度
    小知识:解决EXP-00003的报错
    Oracle删除索引规范
  • 原文地址:https://www.cnblogs.com/sunjianzhao/p/11364615.html
Copyright © 2011-2022 走看看