zoukankan      html  css  js  c++  java
  • poj2431优先队列

     
     
    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

    To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

    The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

    Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

    Input

    * Line 1: A single integer, N 

    * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

    * Line N+2: Two space-separated integers, L and P

    Output

    * Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

    Sample Input

    4
    4 4
    5 2
    11 5
    15 10
    25 10
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS: 

    The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

    OUTPUT DETAILS: 

    Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
     
     
    思路:每经过一个加油站,先不加油,而是认为可以加油,当油箱内的油为0时,则判断当前能加的油量最大值,如此可解。
    #include<iostream>
    #include<stdio.h>
    #include<queue>
    #include<algorithm>
    #define maxn 1000005
    using namespace std;
    struct Node
    {
        int dis;
        int fuel;
    
    }node[maxn];
    priority_queue <int> fu;
    bool cmp(Node a,Node b)
    {
    
        if(a.dis!=b.dis)
            return a.dis>b.dis;
    }
    int main()
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&node[i].dis,&node[i].fuel);
        }
        sort(node,node+n,cmp);
        int p,l;
        cin>>l>>p;
        int  t=0;
        bool flag=false;
        int res=0;
        for(int i=l;i>0;i--)
        {
            //cout<<i<<endl;
            //cout<<fu.top()<<endl<<endl;
            if(p>0)
            {
                p--;
            }
            else if(p==0)
            {
                for(t;t<n;t++)
                {
                    if(node[t].dis<i) break;
                    fu.push(node[t].fuel);
                }
                if(fu.empty())
                {
                    flag=true;
                    break;
                }
    
                p=fu.top();
                fu.pop();
                res++;
                p--;
            }
        }
        if(!flag)
        {
            cout<<res<<endl;
        }
        else cout<<"-1"<<endl;
        return 0;
    }
    View Code
  • 相关阅读:
    Shortest Paths
    Minimum Spanning Trees
    Programming Assignment 1: WordNet
    Directed Graphs
    内连接
    数据中台文档--参考
    ORACLE触发器字段触发
    DTS
    oracle删除归档日志
    OGG 分区表
  • 原文地址:https://www.cnblogs.com/superxuezhazha/p/6360147.html
Copyright © 2011-2022 走看看