zoukankan      html  css  js  c++  java
  • POJ3253 Fence Repair【哈夫曼树+优先队列】

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 48026   Accepted: 15784

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    Source


    USACO 2006 November Gold


    问题链接POJ3253 Fence Repair

    题意简述:有一块长木板,要经过n-1次切割将其切成n块FJ想要的木板。对于每块木板,每切割一次,将会消耗与木板长度值相等的费用,问最少费用是多少。

    问题分析

    根据哈夫曼树的原理,可以得到最少费用。构建哈夫曼树的过程是,先找到两个最小的长度,然后合并,继续这样的过程,直到构建成一颗哈夫曼树。

    实际上,这个问题是求最小代价,并不需要真的构建哈夫曼树,只需要有构建过程就可以了。

    用优先队列来模拟构建哈夫曼树的过程是方便的,模拟过程中算出最小代价即可。

    程序说明(略)


    AC的C++语言程序如下

    /* POJ3253 Fence Repair */
    
    #include <iostream>
    #include <queue>
    
    using namespace std;
    
    struct _plank {
        long long len;
        bool operator < (const _plank &p) const {
                return len > p.len;
            }
    };
    
    int main()
    {
        int n, min1, min2;
        priority_queue<_plank> q;
        _plank p;
    
        while(cin >> n) {
            for(int i=1; i<=n; i++) {
                cin >> p.len;
                q.push(p);
            }
    
            long long ans = 0;
            while(q.size() > 1) {
                min1 = q.top().len;
                q.pop();
                min2 = q.top().len;
                q.pop();
                p.len = min1 + min2;
                q.push(p);
                ans += p.len;
            }
    
            cout << ans << endl;
        }
    
        return 0;
    }



  • 相关阅读:
    svn使用
    navicat 15 安装破解
    thinkpad交换Fn和Ctrl
    emqx_mqtt安装+mqtt管理工具
    Adobe XD使用
    FolderPainter:windows系统为文件夹设置不同颜色
    rest client 代替postman
    使用bfg快速清理git历史大文件
    Adobe Acrobat XI Pro v11.0.10中文版
    Excel 2016打开文档时提示“操作系统当前的配置不能运行此应用程序”
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563754.html
Copyright © 2011-2022 走看看