zoukankan      html  css  js  c++  java
  • PAT甲级真题打卡:1001.A+B Format

    题目:

    Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

    Input

    Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

    Output

    For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

    Sample Input

    -1000000 9
    

    Sample Output

    -999,991

    参考代码:(C++)

    #include<stdio.h>

    using namespace std;

     

    int main(void){

    int a,b;

    while(scanf("%d%d",&a,&b)!=EOF){

    int c = a+b;

    if(c<0){

    c=-c;

    printf("-");

    }

    if(c>=1000000)

    printf("%d,%03d,%03d ",c/1000000,(c/1000)%1000,c%1000);

    else if(c>=1000)

    printf("%d,%03d ",c/1000,c%1000);

    else

    printf("%d ",c);

    }

    return 0;

    }

     

    分析:

    对于负数,可以先判断a+b的结果是否为负,若结果为负数,则先输出负号『-』

    由题目a,b范围,可知a+b的结果的绝对值小于10000000,所以对于大于1000000的部分c/1000000即可。

  • 相关阅读:
    C++ Primer 笔记——标准库类型string
    Windows文件系统
    c++数组
    B+树
    简单搭建FastDFS分布式文件系统(简单易懂)
    什么是分布式系统(通俗易懂)
    对List中每个对象元素按时间顺序排序
    java23种设计模式之一: 策略模式
    微信app支付java后台流程、原理分析及nei网穿透
    quartz多任务调度+spring 实现
  • 原文地址:https://www.cnblogs.com/ton2018/p/8931575.html
Copyright © 2011-2022 走看看