zoukankan      html  css  js  c++  java
  • PAT甲级真题打卡:1001.A+B Format

    题目:

    Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

    Input

    Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

    Output

    For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

    Sample Input

    -1000000 9
    

    Sample Output

    -999,991

    参考代码:(C++)

    #include<stdio.h>

    using namespace std;

     

    int main(void){

    int a,b;

    while(scanf("%d%d",&a,&b)!=EOF){

    int c = a+b;

    if(c<0){

    c=-c;

    printf("-");

    }

    if(c>=1000000)

    printf("%d,%03d,%03d ",c/1000000,(c/1000)%1000,c%1000);

    else if(c>=1000)

    printf("%d,%03d ",c/1000,c%1000);

    else

    printf("%d ",c);

    }

    return 0;

    }

     

    分析:

    对于负数,可以先判断a+b的结果是否为负,若结果为负数,则先输出负号『-』

    由题目a,b范围,可知a+b的结果的绝对值小于10000000,所以对于大于1000000的部分c/1000000即可。

  • 相关阅读:
    oracle 查看运行中sql
    orcale 匿名代码块
    vsftpd 自动安装脚本
    js 第二篇 (DOM 操作)
    js 第一篇(常用交互方法)
    安装部署Solrcloud
    安装部署zookeeper集群
    zabbix-agent active 配置自动探测
    zabbix 3.2.4 安装
    python os模块 常用函数
  • 原文地址:https://www.cnblogs.com/ton2018/p/8931575.html
Copyright © 2011-2022 走看看